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Articles Caught Exception in Agilent 2200 TapeStation Controller Software: Configuration System Failed to Initialize
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  • Created :  10 Nov 2022
  • Modified :  8 Feb 2023
  • Category :  Agilent Knowledge Portal
  • Entry Type :  Article
  • Product Type :  Automated Electrophoresis Software
  • Product Name :  2200 TapeStation Software
  • Task :  Troubleshooting
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Caught Exception in Agilent 2200 TapeStation Controller Software: Configuration System Failed to Initialize

Answer

This Information Applies To: 2200 TapeStation instruments, 2200 TapeStation controller software


Issue:

The Agilent 2200 TapeStation controller software won't launch but displays the correct serial number in the top-right corner of the loading screen.
A specific error message indicates that the configuration failed to initialize (see Figure 1).

 

Figure 1. Configuration error dialog box indicating a caught exception


Resolution: 

A corrupt configuration file is causing this error. As it does not contain any critical information, it can be deleted to fix this error and open the software again. To delete it, please navigate to the Agilent_Technologies folder in a hidden directory on your PC. You may reach it with one of the following two ways:

  1. Either navigate to the folder in the Windows File Explorer by copying and pasting this path: %AppData%\Local\Agilent_Technologies\
  2. Or, when navigating manually in the Windows File Explorer, select the respective folders in the following file path. Please note that App Data is a hidden directory within your user account, so you need to view hidden folders. The path is the following: C:\Users\[your username]\AppData\Local\Agilent_Technologies

In this folder, delete the folder TapeStation_Controller.ex_(...). (...) represents a series of letters and numbers unique to your system, see Figure 2 for an example. This folder will contain only the corrupt config file.

 

Figure 2. How to navigate to the TapeStation_Controller.ex_(...) folder that needs to be deleted 

 

If the issue persists, please generate the log files in the analysis software in the File menu > Help > Export Log Files (see Figure 3). Send the saved .zip file to your local Agilent support team for review.

 

 

Figure 3. How to export log files

Root cause:
The root cause could be related to a special character or symbol used as input in the controller software. To prevent this error from re-occurring, please avoid using special characters or symbols when entering information into the software.

 

 Bulb 
Learn how to effectively troubleshoot your Agilent 2200 TapeStation:
Agilent 2200 TapeStation System Troubleshooting Manual

 

 

For Research Use Only. Not for use in diagnostic procedures.

PR7000-8006

 
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