Firmware Update of 5975C to 7.02.29 failed

Hi, i want to update the Firmware of an 5975C with the Firmware Update program msupdate.exe of OpenLab to Version 7.02.29. At the moment the version is 5.02.09 and this version doesn’t support the new OpenLab. Unfortunately the update aborts at one point and reports cFS: file fransfer size verify failed 2203203 203 MSSC.O. It also reports that USER and PASS is required. Does anyone have any idea how I can fix this problem?

  • unfortunately that did not work either. This is still the error message, that cFS: file transfer size verify failed...

  • I would add that the "USER and PASS required" message is not a problem and is expected to see during firmware update. The username and password is being provided when prompted, it just is not shown. The real issue is the filesize check failure. I agree please confirm that telnet and ftp are enabled on the PC. 

  • Telnet and ftp were enabled, but I think now I've scraped the smartcard because I tried to flash the new firmware version with an older msupdate version. Now the MS is stuck at loading msd firmware. Is there any way to get the smartcard back? Or do we have to exchange it now? See no evil

  • There is more that can be tried before replacement.

    Please go to the start menu, type cmd into the search and before clicking it use the option to launch it as administrator. Navigate to the directory containing the firmware (C:\Program Files (x86)\Agilent Technologies\OpenLAB Acquisition\GCMS\Firmware\5975)

    I would go step-wise: use the cd command (change directory) to navigate to the C:\, then type cd prog and hit tab until you see Program Files (x86). Hit enter. Then cd agil [press tab till you see Agilent Technologies] and keep going until you are in the 5975 folder

    Once in the folder try this command:

    msupdate updateall

    If this doesnt work it may be possible through one other trickier step, though this would require a USB to Serial cable. If that doesn't work then it would be necessary to replace--though I don't think you damaged it with the firmware update. While it IS getting stuck attempting to load the firmware the underlying operating system is very likely still functioning. Hopefully the updateall command will help.

  • The updateall unfortunately also does not work. Yes first the Maschine shows that is loading boot rom and I can still ping it. Then it stucks at loading msd firmware. How does the whole thing work via usb or serial Cable? Many thanks so far.

  • Well, I can send some additional instructions tomorrow -- I am currently traveling in India so it is getting late. It may be best to have an FSE come to try and assist with the repair, but if you're willing to try I can share some advice to try and fix it over serial. If the updateall is failing it may be possible that the storage on the smartcard has become corrupted (not likely due to the firmware update, but just exposed when the firmware update was performed.) Hopefully the serial cable can help resolve it.

  • Yes please, that would be great. I would like to try it myself first. If the smartcard has to be changed, someone would have to come anyway, right?

  • Yeah if the smartcard needs to be replaced an FSE will need to come on site. The process for trying to recover it over serial is tricky, so it may actually be better to just plan to have a service engineer come on site and attempt once more to recover it and then replace it if they cannot fix it.

Reply Children
Was this helpful?