7900 ICP-MS connection problem


since recently I have connection problems between the ICP-MS 7900 and the mass hunter software. The first time a batch process got stuck on one sample. After rebooting the computer, the connection was there again, but it broke off after about 30 minutes. I managed to get a connection once more to turn the plasma off, but when I tried investigating the issues the next day no connection between the software and the tool could be established. Same thing after power cycling the ICP-MS.

The connection is via crossover cable and a LAN to USB connector (since the main lan port of the computer is used). Assuming a problem in the LAN-usb adapter, I tried getting a connection via a small network (computer, ICPMS and router only). During that the IP of the computer was fixed to be within the same subarea (, so not identical to the original crossover+adapter ip address 127) and I switched the crossover cable to a regular cat 5e cable. However trying to ping the tool at it's old address ( was not successful (destination host is unreachable). I also tried the same with the direct crossover cable and with another omputer getting the same result. 

I went through the MassHunter installation guide but did not find anything fitting the situation, since the issue is not really related to the Bootp/Web interface settings but to not having a connection at all. The lights on the LAN port on the ICP-MS 7900 side are flashing and also the one’s on the router were the patch cable coming from the ICP-MS is connected. So I would assume the network device inside the ICP-MS is working.

Any idea how to get the communication running again? Is there a default IP address the tool falls back to? The ICPMS model is from 2015 and the computer is running windows 7.

thanks in advance,

Finn Babbe

  • Hi,

    at the back of the Instrument, in the direct near of the lan cable, there is a network reset switch (a small hole). 
    Press this switch for 3s with a paper clip or something similar. This should bring back the original default up Adress. 
    the 7900 is not controlled by bootp anymore. 

    good luck


  • Hi Finn,

    It sounds like you are utilizing the primary NIC (Network Interface Card) in the PC for another connection (work connection perhaps?). The PC may be prioritizing that connection over the ICP-MS. I always recommend using the PC NIC for the ICP-MS and any secondary connections using a LAN-USB converter. Doing the reverse is technically not supported. You can assign priority in the Network Settings Binding Order.  

    In the Control Panel, navigate to Network and Internet, then Network and Sharing Center.

    Click on Change Adapter Settings. If the menu items are not displayed toggle them on by hitting the Alt key on the left side of the keyboard.

    Then select Advanced then Advanced settings. Under the Adapters and Bindings tab where the connections are listed make sure the LAN connection for the instrument is listed FIRST. If it isn’t, click once on it, then use the green up arrow to the right to move it up.

    If you are still not able to communicate, I suggest connecting the ICP-MS to the PC NIC via a crossover cable, going into Network Adaptor Settings, and making the PC IP to subnet, subnet, and DNS Server empty. Then reset the ICP-MS IP (it will then be as suggested by Chris, and see if you can then ping the ICP-MS. You may need to reboot the PC and ICP-MS. On the bottom right of your windows taskbar, your network notification should at least recognize the connection once rebooted and the red light on the ICP-MS should go away. 

    If it will not ping, you can also check the connectivity via the Web Interface by opening Windows Explorer and typing the ICPMS IP of into the search bar. I've had some rare cases where the system would not initially ping, but once I entered the IP into the web interface it started communicating again. 


  • Hi Chris and Chelsea,

     thanks for your detailed answeres. I tried the suggested fixes and so far did not managed to reestablish a connection between PC and ICP-MS also after resetting the IP address of the ICP-MS. The computer detects that there is a connection as soon as the LAN cable is plugged in or the ICP-MS is powered on but opening the web interface or pinging fails. The red light at the front side of the ICP-MS stays on.

     Is there another option for some kind of hard reset?



     Steps taken:
    Connection via crossover cable now uses the main NIC of the computer. The main NIC was set as primary connection. I found a button labelled "setip" close to the LAN cable port and assumed that is the button for resetting the IP. Pressed it for about 5 seconds, tried connecting (no success), power cycled the ICP-MS, tried connecting again (no success). Tried this in various combinations also with different LAN cables and different computers (all network adapters and cables seem to be working fine). Went through the MassHunter installation guide once more, and checked that all windows settings (user profile, firewall, ect are correct).

  • Hi Finn,

    sorry to hear that. 

    I guess, that there is no Problem with the PC, but with the ICP. The red led indicates an error. It might be, that the instrument has lost the firmware. Or one of the Main PCA or Processor Board has an issue. 

    If the Firmware is the problem, a technician could maybe reload it. If the Boards are the troublemakers, then a technician has to exchange them. 

    that said, it is obvious, that you should contact your local customer service. 

    Good luck


  • Hi,

    Unfortunately, I have to disappoint you, this information is completely wrong.

Was this helpful?