ReportBuilder Assembly version: 12.0.893.0 - keep crashing when editing template

I'm new to ReportBuilder and I recently found a very helpful familiarization guide.  I'm going thru the examples to learn the intricacies of the reports and how to edit them.  I keep getting errors of "ReportBuilder has encountered a problem and need to close".  I've gotten several versions of this error.  I've tried loading a template in Quantitative Analysis 12.0 but the "edit" button is never available.

I currently have purchased two copies of Masshunter analysis software so that I can analyze software in my office, and it's also loaded on the instrument (6495C) computer along with the Acquisition software. I have 12.0 for that as well.

Is this a known issue?  Do I just need to remove and reinstall the software?

I also get "QuantAnalysisWPF has encountered a problem and needs to close".

Any help is greatly appreciated.

  • Hello  ,

    I have moved this to the Mass Spectrometry Software Forum for better visibility.

    I'm not aware of any issues using the familiarization guide with Report Builder 12.0, or any general issues with Report Builder 12.0. Are you following this version of the guide?

    Agilent MassHunter Workstation Software Report Builder Familiarization Guide

    If so, at what point are you receiving the errors?

    Editing a template from the Report Method Editor in Quant will only work for Report Builder templates. You need to select the template row and then the Edit button will be available.

    What actions are you performing in Quant to generate the errors you are seeing there? 

    The only general advice I can give is that if you are installing LC/MS Quant 11.x or later on a data analysis only PC, make sure to run the Permissions/ECM Setup tools even in a standalone installation. With OpenLab integration it is necessary to install and set up a default user and permissions. These are necessary even if logins for running Quant are not enabled. The tools can be found in the Quant Tools and in the Report Builder Start menu groups.

    You can accept the default settings and choose Install.

    If you are not certain if this has been done, it is fine to run these again at any time.

    Another issue that can occur is that even without logins enabled Report Builder still has an inactivity timeout that will lock the editor. If this occurs, simply enter the username as SYSTEM with no password and click Unlock. The username must be in all caps.

  • Hi Howard - thanks for the response.  I have been following the familiarization guide you sent to me.  As I was following it and tried to preview the software crashed.  It will also randomly crash.  I have all Masshunter 12.0 software as everything was installed just this past Oct.  I'm trying to now to do some updates and then I will try again in a couple of weeks.  I'm out of the office next week, so I won't be able to try other things for a couple of weeks.  I'll be back in touch.  

  • Hello  ,

    I have been able to confirm that the Preview functionality was removed from Report Builder 12.x for quant. While the menu items still exist, they will not function. The familiarization guide will be updated in a future release. 

    The best way to test a template is to run it directly from quant. I have always found this preferable because from within quant you can choose to only report certain samples or compounds for quicker and more targeted testing. You can have a template open and saved in Report Builder and still use it in a reporting method in quant. Changes can be made and saved and then quickly retested from quant. 

    For your other issues, make certain that the Defender/anti-virus setup steps from the installation manual have been applied.

    MassHunter Workstation 12.0 LC/TQ Installation Guide (

  • Much appreciated!  I'll try again in a couple of weeks.

  • OK - I've had the opportunity to work a little more with ReportBuilder and I'm getting the hang of it.  I'm running across the problem now of being interrupted when editing my report.  When I come back another day and try to continue to work on creating my custom report, I add a textbox and then go to the textbox properties.  When I then click on the Field Caption and go to the Binding Name to choose from the dropdown menu there is nothing there to choose from. It's an empty list.  How do I get it back connected to show the dropdown list again? I've attempted this going thru Quantitative 12.0 Build 12.0.893.1 and thru the ReportBuilder program separately.  Nothing in the dropdown list.

  • Hello  ,

    To have access to bindings the textbox must be placed in an existing List or Table that contains bindings. This is what populates these fields. 

    The easiest way to check is to right click on the text box and choose the Select-> option. This will show you the hierarchy that the textbox resides in. You want to see something like this, where it is in a Table and/or List.

    And not something like this, where it is just part of the Page.

Was this helpful?