PC cannot communicate with the GC unit in GC/MS system

Dear Agilent Community Members,

I found that the PC on our GC/MS system lost the communication with the GC unit (7890A).
It can communicate with the MSD unit (5975C).
The PC and these units are connected via a switch.
Ping from the PC to the GC didn’t go through (all packets were lost).
Ping from the PC to the MS was fine.
The system was working until August 10th then I found the issue on August 12th.
I saw there were a couple of Windows Updates during that period (including the restart of the PC).

Here are what I have checked.
- All cables and switch for the connection were fine.

- IP address, Default Gateway and Subnet mask were set appropriately.
PC: 10:4:40:170
MS: 10:4:40:169
GC: 10:4:40:168
Subnet Mask: 255:255:255:0
Default Gateway : 0:0:0:0

- I once changed the IP address for the GC to the one used for the MS unit but ping didn't work.

- I tried the direct connection between the PC and GC unit via a crossover cable and tried ping, but all packets were lost.
The direct connection between the PC and MS unit using the same cable was fine (thus, the cable was OK).

- I tried ping using another PC with the firewall stopped, but ping didn’t reach GC (ping to MS was fine).

Based on the attempted troubleshooting, I am suspecting a hardware issue on the GC unit, such as malfunction of the network card inside.
However, I would like to know if there are something I can do before having a service.

Thank you in advance for your help.

Kosuke Ohgo

Parents Reply
  • Dear Ish,

    Thank you for your quick reply.

    I power-cycled the complete system as you suggested, but there was no luck.
    The software is MassHunter.

    An Agilent service tech suggested the malfunction of the logic board (G3430-61820).

    Thank you again for your help.


  • What error you are getting when communication failed?

    Can you share pic of error?

  • Hi Ish,

    On the Command Prompt of Windows, the result of ping was


    Pinging with 32 bytes of data:
    Reply from Destination host unreachable.
    Reply from Destination host unreachable.
    Reply from Destination host unreachable.
    Reply from Destination host unreachable.

    Ping statistics for
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss).

    When I started MassHunter,

    the message was


    GC at IP address did not respond."

    then the software got stopped.

    Thank you,


  • Press option key from gc keypad then go in communication and see what ip address is showing there in GC..

  • It is, that is what I am pinging to and the one on the configuration of MassHunter, sadly.

  • Ok..means IP in GC option keypad is same what entered in PC..

    Can you see any light on back of GC where Lan is connected.

    Led light on network switch hub is not red..

  • I am sure automatic update of windows is off, firewall off...

  • I see the green lignt ON on the logic board. I never see it is blinking though.

    Thank you for sending the document.
    Once I tried ping from another PC with firewall off, but ping got failed.
    I will try ping from that PC after reading the document.

    The security of the PC for the GC/MS is controlled by our ITS.
    They quickly checked the PC yesterday but they didn't change the setting

    because ping from the PC to MS worked fine.

    FYI, it looks that MassHunter recognizes the MS, too.

    Thank you again,

Was this helpful?