PC cannot communicate with the GC unit in GC/MS system

Dear Agilent Community Members,

I found that the PC on our GC/MS system lost the communication with the GC unit (7890A).
It can communicate with the MSD unit (5975C).
The PC and these units are connected via a switch.
Ping from the PC to the GC didn’t go through (all packets were lost).
Ping from the PC to the MS was fine.
The system was working until August 10th then I found the issue on August 12th.
I saw there were a couple of Windows Updates during that period (including the restart of the PC).

Here are what I have checked.
- All cables and switch for the connection were fine.

- IP address, Default Gateway and Subnet mask were set appropriately.
PC: 10:4:40:170
MS: 10:4:40:169
GC: 10:4:40:168
Subnet Mask: 255:255:255:0
Default Gateway : 0:0:0:0

- I once changed the IP address for the GC to the one used for the MS unit but ping didn't work.

- I tried the direct connection between the PC and GC unit via a crossover cable and tried ping, but all packets were lost.
The direct connection between the PC and MS unit using the same cable was fine (thus, the cable was OK).

- I tried ping using another PC with the firewall stopped, but ping didn’t reach GC (ping to MS was fine).

Based on the attempted troubleshooting, I am suspecting a hardware issue on the GC unit, such as malfunction of the network card inside.
However, I would like to know if there are something I can do before having a service.

Thank you in advance for your help.

Kosuke Ohgo

Was this helpful?