7700 Sample Data Acquisition Does Not Stop AND MassHunter Software installation issues

Hi All,

I have an Agilent 7700 ICP-MS running MassHunter 4.6.  Interesting issue - the instrument tunes just fine but when I go to run a sample, the data acquisition never stops; it continues well past the time it should have taken including rinse program etc until the run is aborted.  This happens on both well established methods that have been used for months as well as new ones.  Working with Agilent support, they did not have a definitive answer and suggested I might need a software reload.  Just thought I'd throw this out there to see if there is a simple fix that someone may have stumbled across.

That said, I did try a software reload and ran into a separate issue.  I downloaded the software from subscribenet, mounted it, modified the UAC, and regardless if I try to modify or uninstall the software I get an error 0xe0434352 - Unspecified error..  I can provide the error log if needed - the last several entries include annotations for Failed to execute EXE package and failed to configure per-machine EXE package prior to session end.  I saw something similar posted here for a new installation on a laptop (mine is a re-installation on what was a functioning system) but there was no followup from the original poster as to whether any of the suggestions actually fixed the issue. 

Any thoughts would be greatly appreciated.  The software has only been out of warranty 2 months and I really don't want to have to pay for a service install for relatively new software.

Many Thanks!

  • Hi,

    Maybe the problem is that the Queue is corrupted or other configuration files are bad.

    it's worth it to reset the full configuration of the ICP-MS MassHunter software. Then maybe the program run like before, after setting the right configuration (like autosampler) back again.

    The reset could be done automatically with the IcpMHSWDiagnostics.exe program.

    the program could be find in C:\Program Files\Agilent\ICPMH\Utilities. Best is to run it like admin.

    Good luck,

    Edgar

  • Hi Edgar,

    Many thanks for your detailed reply.  I very much appreciate the assistance.  So I found the executable and tried to run it.  I received the following Windows error...

    If I skip the installation, the program does not seem to run.  Do you recommend allowing the windows update in order to proceed? I ask because I seem to recall somewhere in the installation documentation that windows update was to be turned off - perhaps I am recalling incorrectly.

    Many Thanks,

    Tom

  • Net Framework 3.5 (non-http) is required by ICP-MS MassHunter. I highly recommend to install it before you try anything else. We do not recommend to disable windows updates, we only recommend to disable "automatic" windows updates to be on the safe side, if a windows update might potentially cause a problem. 

  • Make sure that "Manual Acq Start ON/OFF" is not selected on the Queue toolbar. If selected (highlighted in orange), the batch will run the first sample and never proceed to the second

  • Good Day All,

    Thanks to all for the great assistance with this issue.  I am happy to report that following the advice received here has resolved the issue and I am up and running again.  So should anyone else ever be faced with this issue, I would recommend you:

    • Verify that the "Manual Acq Start ON/OFF" is not selected on the Queue toolbar - this is the simplest thing to check first
    • Run  IcpMHSWDiagnostics.exe in the C:\Program Files\Agilent\ICPMH\Utilities directory
    • If you have any issues running the executable as I did, then update/install Net Framework 3.5 

    That solved my issue.  Again, many thanks to my learned colleagues on this site who saved me a full software install at best and potentially even the cost of a service call.

    Best Regards,

    Tom

Was this helpful?