Cary 100 - Validate Comm Error 9.9CSM

We have an old Cary 100 that was running fine with a WinXP laptop using the GPIB-USB-HS cable/adapter.  Unfortunately the WinXP machine, old and decrepit, died recently and the drive was not recoverable.  To minimize possible hiccups I found another WinXP machine on eBay and installed the Cary software from CD and installed NI 488.2 - 2.6 version I believe.  Most things work except Validate.  On launch I get an error reading "9.9CSM - Input Message Length Error" after a few seconds.  I can see, sometimes, the Cary moving thru the wavelengths but no tests are available.

I have searched the internet and apparently nobody else has ever had this error and/or chosen to write about it on public forum.

In past, before the WinXP machine died, I had tried to move to a newer laptop running Win7 or Win10 and encountered this same error and I (wrongly I guess) attributed it to the OS.

Other thing I see is on WinXP start - error EVsgException in module Cary32.dll at 0004E46D.

If anybody has ideas I would greatly appreciate.  Have spent way too many hours trying to get this working.



  • Hi Jim,

    1. the Cary32.dll error is because Cary software is 32 bit, not 64 bit, therefore it should be run from 'C:\Program Files (x86)' not 'C:\Program Files' which is for 64 bit programs, (your Agilent directory should be under the x86) but that's the minor problem.

    2. I only have experience with the Cary 60 UV which is simple USB but we use GPIB for the old HPLC, not other stand alone equipment like UVs. Does the Cary 100 also use WinUV Software, if so, which version?

    3. Validate is your biggest program for the calibration people, do you follow USP or BP protocols for calibration? Are you using the Pharma version of WinUV with the version extension .1042?

  • Appreciate you taking time to answer.

    This is an ancient version of Validate - circa 2003. Installed it and other stuff with original CDs. 

    I am not the user of the Cary, so not sure what gets used - but mostly it's just simple absorbance measurements for pH and such.  I am just the guy who sometimes can get equipment working.

    The WinXP Pro is 32 bit and the Cary32.dll is in c:\Windows\System32 which seems like right place.  There is no (x86) on this machine.

    Have tried various compatibility settings to run it.  Wiggled the settings of the GPIB-USB driver that seemed like they might affect message length - but that's just shooting in the dark.



  • "Cary moving thru the wavelengths but no tests are available." Check the setup and communication with SDA? Maybe try restoring and archiving to it separately? Make sure there's space, express has a size limit.

  • The current version of NI-488.2 does not support Windows XP, so you will have to download an older version. NI-488.2 version 15.5 was the last to support Windows XP and the GPIB USB-HS.

  • The last time I checked NI.COM older drivers prior to Windows 10 are no longer available.  Perhaps they have them archived. 

  • For others who may find this interesting.  Looking at the GPIB set up with NI MAX you see 2 'instruments' with primary addresses of 9 and 20.  The instrument at '9' seems to work fine.  Thus I can see the machine warming up and going through the wavelengths when it's first booted.  The instrument at 20 has an error shortly after first poll, the ibrsp command gets an invalid handle error.  I looked at some of the documentation of GPIB, but not sure how much I want to dig down into that if ultimately it's an issue (as suggested by others) with the NI-488.2 version.  Will see if rolling back to 15.5 works.  Ironically I only recently threw out a whole bunch of old NI CDs for our very long running LabView subscription that might have been helpful.  Sigh.

Was this helpful?