Report Method Not Being Used When Automatic Reporting Results in Sequence

We are set up to analyze and print a report after each sample in our sequence. In preparing for this, we modified one of the included Excel templates and used MassHunter Quant to create a report method. When printed manually from Quant, the report shows everything as expected. However, when using automatic analysis and reporting in our sequence, the report doesn't contain the formatting we set in the report file (peak labels on the chromatogram). Also, the graphics files we set to be deleted after report generation are not being deleted. It appears that the report file we made is not being used. Our Excel template that we used for our report file and that we set in the sequence is definitely being used. I guess my question is how does automatic analysis/reporting know which report file to use? The report file does not seem to be referenced in the data analysis method (I searched the xml file for the report file name and it wasn't there), so not sure how this works?

Thanks!

-David

  • Hi

    if you are using Quant automation DA , then the reporting method is shown in the lower box , just select the method of interest 

    <<<<<<<<<<<<<<<

    If you are  Using Qualitative automation report , then you just need to select a qualitative method , 

    but first open the masshunter Qual and open your method and go to method editor -> method workflow

    and select your workflow and reporting template ( you can edit any template ) then save your method with a name eg. Qual DA method

    now select your Qual DA method from acquisition 

  • Thanks for responding! I should have mentioned that we are using MassHunter Acquisition 10.0 and MH Quant 10.2 for single quad GCMS, so I don't see the dialog box that you provided in our software.

    I did note that in our data analysis method xml file, I see two entries - ReportDataVersion="" and ReportDataPathFileName="" - which are both empty. I'm wondering if those should contain information about the report method file?? 

    -David

  • Hello again

    sorry i replied you with LC MS masshunter software , i didn't see your mention

    ok ,, For GC MS

    go to ( edit sequence )

    right click and select columns

    add new columns to your sequence ( DA path , DA file , DA result template )

    fill them correctly , and good luck

    don't forget to select & save your printing method from DA method ( printer or pdf or excel )

    please feed me back if it goes well ..

  • Thanks again for your response!

    I have the DA method, path, and Excel report template in the sequence table. The problem is where to indicate the DA report method to use. The report method includes settings and formatting info for the graphics and other stuff (like labeling peaks on the chromatogram, deleting graphics after report generation, etc.). I thought the reporting method should be saved with the DA method, but it is not. Manually editing the DA method xml file by adding the path and name of the DA report method doesn't seem to do anything. The report prints using the correct formatting, graphics, etc. when manually generated from Quant, but not when using the automatic DA and reporting (see examples below).

    Chromatogram from automatic data analysis:

    Same chromatogram manually printed from Quant:(desired output)

  • Hi again

     try the last hope ,

    first try to select your reporting method in ( DA report template ) , the sequence accept it but i don't know if it will success to print ,

    you may try it

    the second thing if the first failed ,then try to edit your report template in ( report builder ) software instead of applying post report process actions , 

    you may get a better options

    you can find the same graphic options like peak labeling with name or other parameters , you can apply labeling on TIC ,, etc

    if you are familiar with report builder it will become very easy for you

  • Thanks again for your persistence in trying to answer my question. Your first suggestion solved my problem - entering the report method name (xml file) into the column in the sequence that asks for the Excel template name (xltx file). For others using this solution, enter *.xlm into the filename blank of the Open file dialog box to allow picking your report file (or you can just type in the full file name instead of picking it).

    For the Agilent folks monitoring these forums, I would suggest this be included as a bug fix in the release of MassHunter Data Aquisition. Not only is selecting the report file for the DATemplate non-intuitive, the software actually discourages the user from entering their report file xml file there in the first place.

  • Hi David,

    With versions of MH GCMS Acq prior to 10.1 it is possible to specify a report template directly into the DA Report Template column in the sequence table. Starting with MH Acq 10.1 we now require that it be a DA Report Method. For 10.1 and newer the column has been renamed to DA Report Method instead of DA Report Template. 

    Here is the info from the 10.1 readme:

    Sequence-based Data Analysis: In previous revisions of this software it was possible to specify either a report template or a report method in the sequence table column DA Report Template. Beginning with MassHunter GC/MS Data Acquisition 10.1, it is now required that users only select report methods when using this column. For this reason, the column has been renamed from DA Report Template to DA Report Method, and the file types that are available for selection have been restricted. When the user clicks browse, the file types that may be selected are: *.m, *.quantreportmethod.xml, and *.unknownsreportmethod.xml.

  • Thanks for the response! I am sure that was a welcome addition for many folks!

Was this helpful?