Function not defined for arguments supplied when loading method error. MassHunter 10.1 Compliance mode

I have been having a problem with Masshunter Data Acquisition v 10.1 in Compliance Mode. When trying to load a method I get a error stating “Function not defined for arguments supplied”. For the life of me I could not clear the error out. Reinstalling the software didn't fix the issue along with a host of other things. I noticed that when I tried to log in there was a message for ECM Failure recovery log. I have always allowed it. The last time I tried to log in I said no and cleared the ECM failed log entry so it wouldn't try again.

I tried to load a method and it loaded without an issue. Tried to load a sequence and it loaded with no issues as well (use do have an actual message stating that the sequence loading was being cancelled on it's own). Has anyone seen this error before?

  • I don't know if this applies to your specific problem, but a lot of failed uploads and other problems can arise because the GCMS users don't have the proper privileges in ECM.  Below is an image with the proper privileges.  Assigning the ECM Contributor and Folder Administrator role will give the necessary privilege's but also a lot of extra privileges.  My recommendation is to create a new ECM role called GCMS_MH_Acquisition and then select the following privileges.  Make sure all GCMS instrument users are assigned this role in ECM.


  • Hi ,

    I just wanted to follow-up to see if your question has been answered. If so, please come back to the post and click Verify Answer on the response so it will make the solution more visible, or update us on what you were able to find.  If you still need help, just let us know and we would be happy to continue working with you.

  • So I actually did find out the issue. The rights that you posted were correct in my environment. What I found was possibly a corrupt method. I found another system with the same method. I renamed it, loaded it, and it worked without an issue. One thing I will note is that it had to be a different name than the method that was giving me issues. I tried to rename the good method the old method's name and got the "Function not defined for argument supplied" error again. This was after I removed the bad method from ECM. Named it something else and it loaded with no issue. Very weird. 

Was this helpful?