TQ fails to initialize/connect after connection is closed with MH12

I mostly work with Ultivo instrument using 1290 pumps.  Until recently, the instruments were being installed with MH1.2 but now there are a couple instrument that have MH12 installed.  I have some experience with this software overall and when doing the general workflow stuff MH12 is working mostly as expected.  When I do close the connection of the instrument I have an issue with connectivity.  Giving these errors:

We've experienced other connection errors as well, but I'm not yet sure those are related.  Eventually I can get the connection back and things generally work normally after that point, is this something anyone else has experienced? Is there some sort of fix to this?
I updated to MH12.1 hoping that would help but that doesn't seem to be the case.

  •  , I am sorry to hear about your issues with Ultivo and MH 12.1. 

    • How are you launching MassHunter 12.1? 
    • What is the ESW/FW on the Ultivo?
    • Have you configured the instrument recently (after upgrade to MH 12.1)?

  • additionally, could you elaborate on this? " When I do close the connection of the instrument I have an issue with connectivity.  Giving these errors:"

  • I appreciate your answering my post! 

    • I tried launching in the Control Panel, with the correct project selected.  I also tried to launch MH12.1 using a desktop shortcut made for that project.
    • I'm sorry, I'm not sure what ESW/FW refers to, could you clarify?
    • I have not, tried to change any configurations of the instrument, since after the upgrade I couldn't get a connection to the TQ.  Since there is no connection, I'm assuming I could configure or update firmware either.  
      • Quick note: this is something that was happening before the upgrade to MH12.1, the instrument was installed in December and has only started to be used on the third of January.  It's only been shut down a couple of times for demonstration purposes and now that there is a definite pattern, I'm reaching out to fix it.
    • What I mean is, when I close the MH Acq and MH Quant, then in the Control Panel I shutdown engines by selecting Close Connection in the Actions ribbon, I get a pop-up that states:
      • "Instrument connection failed. Application will now exit. Please check system activity log for additional information." 
      • Then the System activity log shows "Engine Launcher: Failded to Start System Engines. Failed to initialize 'TQ' device. The connection is already closed. Safe handle has been closed." 
        • and "Acquisition Engine: Failed to initialize 'TQ' device.  The connection is already closed. Safe handle has been closed."
      • (I attempted to include screenshots in the original post, if those aren't showing for you I'd appreciate know so I can be aware for future posts.  Thank you)
  • I would recommend reconfiguring the TQ as a way to test communication with the TQ. If there is a communication issue, it will not be able to retrieve the serial number or firmware (FW/ESW) revision. 

  • Thank you! This seemed to have helped.  I'll have to test over days (or weeks) to be confident this issue is actually resolved, but I am now able to connect and launch MH12.1 and control the instrument as expected.  I'd also like to thank you for your promptness and detail!

Was this helpful?