Agilent 7890A GC Front Inlet Pressure System Shutdown

I have an Agilent 7890A GC-FID with dual split/splitless inlets and detectors configured with a 0.53 mm ID capillary column. My instrument keeps giving me the message "front inlet pressure, system shutdown".  The front inlet cannot maintain pressure and the unit shuts down. On start up the front inlet pressure does reach the setpoint (5.96 psi), albeit sluggishly, but a few seconds later the pressure drops off by about 1.5 psi until it reaches a certain point. Then the pressure begins to slowly increase again by 0.001 psi/sec but never attains the setpoint and I get the error message. I'm working in splitless mode with N2 carrier gas and gas saver on, but I've gotten the same problem in split mode. I switched the column to the back inlet and the problem arises there too.


Agilent technical support told me the symptoms present as a leak, but everything I've tried has been unsuccessful. I've replaced the inlet septum, liner, liner o-ring, gold seal and washer, graphite ferrule, and zeroed the pressure sensors. I also cleaned in and around the inlet with methanol. I checked all gas connections with an electronic leak detector and did not find any leaks. The worst case scenario is a bad EPC(s), and I'm hoping we don't have to replace that! Any suggestions or insights would be greatly appreciated. Is there something I'm missing here or haven't thought to rule out? This is my last effort before I result to an Agilent service call.  Thanks!!!

  • Hi dan_hockersmith,

    Can you give us your parameters for the inlet? Particularly the total flow for the inlet and mode you are operating in.



  • N2 can be a challenge as a carrier gas especially with 0.53 columns and low oven temps. Has the GC been configured in the software for N2 as the carrier? What temp is your oven at while trying to apply these flows? I have attached a procedure that will allow you to pressure/leak check the inlet.


  • I should clarify that typically the inlet temp is 270C. I had it turned down to 100C so I could see if the pressure would get to the setpoint as the inlet temp increased, but only makes 4.000 psi at start up and drops off shortly after. I believe the GC is configured with N2 carrier gas in the software. I typically use the computer to control the instrument. The oven temp has been at 40C while troubleshooting this, the setpoint is never made so I can never run the method and the oven doesn't get any hotter. On a good run it goes to 300C. I'll try the leak test, but I did use an electronic leak detector around the inlet an found no leaks.

  • Hi Dan,


    Could you disable your gas saver setting and post your column dimensions and flow along with the new inlet total flow?  Gas Saver is a feature that meters down the flow to limit consumption, so troubleshooting with it enabled can lead to inaccurate conclusions. Also be aware that electronic leak detectors aren’t optimal tools with nitrogen or air supply gases because they cannot discriminate between ambient air and the supplied gas you are trying to detect.   Most leak detectors that are commercially available work based on thermal conductivity differences between atmospheric air and the supply gas.




  • Abbey,


    I've turned off gas saver mode to the back inlet.


    The column is a Restek RTx-5 w/ dimensions: Length 30.0 m, film thickness 0.5 um, ID 0.53 mm

    Parameters: flow 8.998 mL/min, pressure SP 5.966, actual 5.966, velocity 59.0, constant flow mode.


    Back inlet: new total flow 62.00 mL/min, pressure SP is 5.966 psi and the actual is 5.966. Seems to be holding steady and software is indicating the system is ready for pre-run. Something happened by turning off gas saver mode. Seems to be holding pressure fine now, go figure. I will try a run and see how it goes. I'll try James leak-test suggestion after that and report back.



  • Hi dan_hockersmith,

    Gas saver set at 20 ml to supply the inlet is the normal setting. It could be, because we are dealing with mega-bore columns, that the saver needs to be set higher. Your column flow is pretty high at 9 ml/min which leaves 11ml/ min to manage the rest of the inlet. Leak tests are always good, but in this case I suspect it will pass. Its possible the settings for the method were marginal with gas saver.



  • Abbey and James,


    I was able to run a sample with no issues. The inlet pressure was right where it was supposed to be.  Not sure why having gas saver mode turned off seemed to fix the pressure issue. I'm afraid to turn it back on now, but I've had it on before and had multiple good runs. As for the leak test, I don't have an 1/8" swagelok cap for the split vent, so I haven't tried that. I don't think there is a leak, because I would think that a leak would persist regardless of gas saver mode being on or off. That seems like sound logic to me, but maybe there is something I'm missing here?

  • Dear Dan,


    We have seen similar instrument problems as well from time to time in my company.... :-)

    Very often this kind of problems are related to wrong GC column configurations....


    Please check that the correct column dimensions are configured in the instrument as well as the correct type of carrier gas. If not, the instrument will not be able to use the corrcect parameters for the actual column used. Especially 530 µm wide-bore columns using low pressures and high carrier gas flows are sensitive to wrong GC configurations.


    Good luck!


    With kind regards -

    Lars Kürstein, Copenhagen

  • Glad to see the other folks have helped you.  I was having some issues with our 7890, but it turned out to be a transfer line leak.  The nut that went into the 6 port valve of the purge and trap sheared in 2 in the valve.

Was this helpful?