ICP-MS 7700X abrupt shutdown.

Hi,
ICP-MS 7700X plasma shuts down abruptly after a while. The software cuts off communication without any error codes occurring. At the same time, the vacuum pump also turns off. We tried to fix the problem by inactivating the power button of the device, but the problem could not be solved. We connected the vacuum pump to another power source but again the problem was not resolved. please help with the problem!

Best regards.

  • Hi

    There could be many reasons of plasma shutdown after a while.

    Air leak in sample compartment.

    Water circulation problem around rf coil.

    Gas flow is not constant.

    Air going in sampling line.

    You can check above things but if still, there is issue then better to call your local agilent suppprt for onsite troubleshooting.

  • It sounds like your power supply may be overheating or has failed if you are going directly from analysis to shutdown mode. Please proceed with cation as abrupt loss of power can further damage the turbo pump. Because of this I would recommend immediately beginning the process of opening a service call. One thing you could try is with the instrument off, gently remove any dust from the rear of the instrument. Also please ensure the voltage from the wall outlet meets the required specs 

  • Hello there, please allow me to jump in to this conversation. The condition is same with our 7700 ICPMS that currently happen several days ago. We also pointed the power supply as suspected error part, so that we try to install another brand new power supply and the problem persist. We also try to install a brand new control board (a board next to main board) because when the instrument shuts down, it lost communication and vacuum pump shut off as well, but the problem still happen. Our last attempt was install the brand new RF generator but it still the same and make me really frustrated. fortunately, all parts that currently installed are supported by Agilent local representative here for testing in sake of finding out the problem. Today, our plan is to try another mainboard to test, but there is no stock for that so that till now we can not use our instrument. We also already checked for the voltage and current from the wall outlet and also the UPS. Hopefully through this forum I can get another insight to find out the true problem. thank you

  • Thanks for sharing your experience. If you fix the problem, I would be very happy if you could share it again.

  • I would suggest:

    1. bypass your UPS by plugging directly into the wall outlet. There could be a fault with the UPS

    2. Replace the ICPMS power cable, It may be overheating 

  • Yes sure I will, hopefully we can solve this problem

  • thank you for your suggestion, I will try it out.

Was this helpful?