A-PLUS software release 2.0.2 not working on new Windows 11-PC!

The Software does not seems to start on the surface pro 8 on windows 11 Professional. on A surface go 2 with he exact same build it works. how can we change that? if we enter the adress in edge it says: "ERR_CONNECTION_REFUSED"
Same issue occures on another new surface pro 8. How can we fix this?

  • If the A-Plus software works on your Surface Go 2 but not the Surface Pro 8, it it probably the way the communication ports are designed or configured. This is the first time I've learned of anyone using A-Plus on a windows surface of any kind.

  • ok. But can you tell me, how i can fix this problem?

  • I will have to ask our engineering team in Italy, because we have no documentation or set-up procedure for A-Plus an on a Surface device.   

  •  Are the MOXA drivers updated on Surface Pro 8?

  • I already updated it. The Problem is, the Software does not even start. I dot NOT have the problem of not finding devices but of the Software not Starting at all. Nothing happens. 

  • I am still waiting for assistance from Engineering.

  • Otis,

    This is the reply from Engineering:

    the connection refused error indicates that the A-Plus server is not reachable, this can happen for two reasons:

    • The server has gone into error, in this case it is possible to launch A-plus from a dos prompt to get the details of the error. From dos you must first give a cd command to go to the folder where a-plus is installed, by default: C:\Program Files (x86)\APlus then from this folder you run the start command to start the server. If the server fails a detail message should be printed, otherwise the program will get stuck on the line:

     Server started, listening on port 2324 network: 127.0.0.1 v3

    (see image below)

    If the server starts, you can open a browser and navigate to the address: http://localhost:2324 to start the Aplus client. Again, if the server goes into error, a detail should be printed in the DOS window.

     This is an example of how A-Plus works properly

    • The second possibility is that there is something that prevents the browser from navigating on the server, but in this case it would be an application or a specific setting of the device and therefore much more difficult to identify.
  • This is my outcome and the end of all actions.

  • it Seems the ap-node.exe and ultimatly the java script does not launch. Could that be a possibility?

Was this helpful?