Masshunter Quantitative Analysis - Error "Calibration STD path mismatch between target and ISTD"

I am still learning Masshunter Quantitative Analysis for LC/TQ and I have version 12.1 build 12.1.938.3.

I have run into this error multiple times and the only way I've gotten out of it so far is to close the software and start over.  This is very frustrating as I go into edit a method and assign Surrogates to ISTD and then Targets to Surrogates.  Once this is done, I go to "Exit" and try to analyze or quantitate the batch.  I then get this error: Calibration STD path mismatch between target and ISTD.

I have not found a way to save what I've done and close the software to try and get out of this error. I'm not finding any information online on how to fix this error.

I would love to know how to fix it without losing all of my work and not creating 15,000 copies of a method since I'm not done with creating the quant method.  A lot of times they open as "read only" and I also have to start over.

How do I fix this error?  Do I just need to move the ISTD and cal.d files to a different folder?

When I'm in Quant and create a new batch, I then go to "Open and Apply from Existing Batch".

I'm sure I'm missing something easy but getting very frustrated here.....

  • I don't really know how to fix it officially but I can tell you how to get rid of it without closing the program. It has to do with the cal paths that are imported when you use calibration->replace calibration. Just go to the add columns option and view cal paths and you will be able to see which calibration standards have paths associated with them. You can just delete those calibration levels and re-add them again. It will clear the cal path and you won't see the error anymore. If there are hundreds of analytes, just clear and re-add everything from one compound and copy those levels to every other compound. You can try using the "generate cal levels from calibration standards" but this only works like 25% of the time in my experience. You need to make sure all ISTDs have the exact same cal levels as all of your analytes. You have to manually type each ISTD

  • Thanks for the suggestion.  This didn't work for some reason.  must be a bug in the newest software.

  • Hi, 
    when u creating batch, do you have Type as sample or cal? If cal change to sample before analyze batch and integrate all peaks, if u get that error again, double click on error it will navigate you to wrong path and type same path as your analytes(or istd), depends what path is wrong

Was this helpful?