Profinder 10 error


Profinder Version: 10.0.2, Build (Windows 10)

I have been trying to do feature extractions (batch recursive or targeted) however, I am getting the following error message pop-up.

"The following analysis file(s) had errors:

Object reference not set to an instance of an object. Please remove the file(s) and re-run feature extraction"

(Note, it seems the error message should list problem files but none are listed)

Once I press OK,  I can look at the Compound Groups Table and Compound Details Table which are populated; however, nothing is shown in Chromatogram Results nor in MS Spectrum Results. The above error reappears if I click on any of the rows in the compound groups table. Consequently I am wondering if this is a problem with the graphics?

I have tried uninstalling and reinstalling profinder with no success.

Any suggestions?

  • Hello  ,

    What type of data files are you trying to process? Have you ever successfully processed this type of data before? Are you able to process any of the shipping example data successfully?

  • Hi, thank you for your reply.

    I am trying to process metabolomic sample .d files generated from an LCMS-QTOF. I did not get this problem a month ago, however, to solve other problems with permissions I had to uninstall and reinstall profinder.

    I have tried a couple of the Agilent example .d files and get the same issue.

    Strangely, some previously acquired samples are being processed fine. As far as I can tell, there appears to be nothing different between sets of .d files that it is able to process and those it cannot. Bizarrely, I have just seen that all the files it is able to process normally were from negative mode MS, whereas the ones it is failing to process are from positive mode MS - I assume this is a coincidence and something else is up, but I cannot find any other obvious difference between the files.

  • Hello  ,

    There is a known issue in Profinder 10.0.2 where you may receive this error if Peak spectrum background is set to anything other than None. 

    Try setting this to None and see if the error goes away.

Reply Children
Was this helpful?