MassHunter Quantitative method is not matching to library for specific compound


Any idea why 3 of my compounds below do not produce a match in any sample?

See spectrum - usually you'd see the head-to-tail

See N-acetyl-L-Leucine 2TMS, there's no match score

The reference library contains NIST spectra for all these compounds. 

This is a standards pool, so I know it is there. It will match by deconvolution/lib search.

The QL ratios are within range.

I tried modifying Integration Parameters Peak filters, Lib Match Score outlier, Correlation Window, fwd-rev score, and many other things. I picked this example because it does not have any co-elution.


  • Hello  ,

    Check and make certain that the name and/or CAS number of the compound in the reference library exactly matches the name and/or CAS number in your quant method. Test to make certain that you can get a match score using only your reference library and not a library method. If you are using a library method and you have RT matching enabled, verify that the compounds are at the expected RT/RI. If they are not, then depending on your penalty you may not receive a match score. 

  • Thanks Howard! Names/CAS numbers were not the same. This solved the issue for the Reference Library. I also made sure that the spectra used in the method were also available in my in-house library. However, when only using my library (and not including the Reference Library in the Library Method nor Globals), I still don't have a match for 2 compounds. At a loss as to why. I disabled RT matching.

    Here's one of them (in a standards sample). What else should I look at? There are 4 compounds within that ~0.2 min window, but if I used deconvolution manually it finds them easily. I am using Agile2 as integrator. 

  • I answered my above question - it's the contaminating peaks that's the issue for these specific compounds - ( because of the 0.7 forward search).


Reply Children
No Data
Was this helpful?