MassHunter SDK and MH 10.1

I have installed the MH SDK and I'm trying to start some scripting in MH 10.1. I'm using VS 2015 with updates and IronPython 2.75, as recommended in this post (

Following the videos included with MS, I tested the "" script with the error, and instead of Visual Studio loading the script file and showing the error in the IDE, it is displayed as a message box in the Quan window. 

Is this due to using the newer version of MH? If not, how can it be fixed so that the debugger behaves as it's supposed to?

Thanks, in advance...!


  • Hello ,

    I tested this in my Quant 10.1 SDK setup and it worked as expected. When I ran the bad script file in the debugging copy of Quant it opened the python file in Visual Studio and provided the same error.

    Are you able to successfully launch Quant from the debugging script? 

  • Hi Howard,

    Yes, Quan launches fine from the script. 

    I tested it on a fresh W10 installation on a virtual machine and it all behaves as expected using either Quan 9.0 or 10.1. Therefore, it must be something on my main installation. For the time being, I will do the script development on the VM

    Thank you for your reply,



Was this helpful?