Masshunter Optimizer - Output file (.xml and not .pdf)

Good afternoon,

I hope someone will be able to assist with the following inquiry:
I am currently optimizing compounds, unfortunately the Masshunter Optimizer software for 6400 series QQQ (B.08.02) only gives an .xml report as an output file and not a pdf report.
Is there somewhere on the software settings where I can change the report output file to .pdf? If yes, where and how do you do that? Could this be due to a software error? Should the software be re-installed?
Best regards,
Elmarie
  • Hello ,

    I apologize for the delayed response. Unfortunately this can be an issue with Optimizer. One possible cause can be having a space somewhere in the data file path name. While this is allowed by the OS and MassHunter in general, in some cases it can cause issues with Optimizer report generation. So avoid using 'D:\MassHunter\Data\My Files\Optimizer' and use 'D:\MassHunter\Data\MyFiles\Optimizer'.

    If this is not the issue then one workaround is to use the attached Windows batch file, which for download purposes is attached as a text (.txt) file. Download this and change the extension to .bat so it can be run as a Windows batch file. When this batch file is run it will ask for the Report folder path. You can copy this directly from the Windows file explorer by going to the folder that contains the Reports folder and then while holding the shift key right click on the Reports folder. You will have an option to Copy as path. Once you have copied the path, right click in the batch command window, choose Paste, and press Enter. If you now go back to the report folder the .pdf file should be present. 

    2425.OptimizerReportGenerator.txt
    set /p reportdirectory=Paste the \report directory path here:
    START C:\"Program Files (x86)"\Agilent\MassHunter\Workstation\Acq\bin\AgtQQQOptimizerReport.exe "%reportdirectory%"

Was this helpful?