Mass Hunter Qual v7.: Lag and error when opening files.

Hi Community, I am getting a new error ever since a Windows update with all of my MassHunter software. It takes some time to open the files and I get the error below. My clock is set to the correct time and managed by my institution.

Date and Time: 5/10/2021  10:51 AM
Program: Agilent MassHunter Workstation Software Qualitative Analysis    B.07.00
Build Configuration: Release
Message: String was not recognized as a valid DateTime.
Stack Trace:    at System.DateTimeParse.Parse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles)
   at Agilent.MassSpectrometry.CommonControls.AgtFolderSelectionDialog.ListViewItemDateComparer.Compare(Object x, Object y)
   at System.Windows.Forms.ListView.CompareFunc(IntPtr lparam1, IntPtr lparam2, IntPtr lparamSort)
   at System.Windows.Forms.UnsafeNativeMethods.CallWindowProc(IntPtr wndProc, IntPtr hWnd, Int32 msg, IntPtr wParam, IntPtr lParam)
   at System.Windows.Forms.NativeWindow.DefWndProc(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ListView.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

  • Hello ,

    This is not a known issue, but in general for date or number format errors the first thing to check is to make certain the Windows region settings are set to their defaults. You can check this in the Regions section of Windows Control Panel. If the files being processed were acquired on a different PC you may need to verify both PCs are using the same date format settings.

    Another thing to try for any unusual Qual errors is to use the Restore Qual Settings utility found in Start menu under Agilent->MassHunter Workstation->Qualitative Analysis B.07.00 Tools. This will delete all user preferences files, such as recently loaded file locations, layout preferences, etc. so that Qual can make a clean set of user preferences on the next restart.

  • Thanks for the reply Howard, but the reset didn't work and the Windows regions are correct.

    It seems like Qual is having a hard time indexing files for some reason. It is very slow to open to the screen where the "Open Data Files" window pops up. I have tried to uninstall and re-install with the same result.

    Is there another version available that I can try or do we need a new license to upgrade?

  • ,

    If you choose 'Cancel' at the open file dialog are you able to finish loading Qual? Have you tried to open a data file without loading results, loading the worklist method, or running file open actions?

    You may also want to attempt some general PC maintenance, such as deleting temp files, freeing up hard drive space, etc. 

    Qual 10.0 is the current shipping version, though what you are describing is not a known issue, so I can't say for certain that this would resolve your problem. You would need to contact your local sales team for a quote regarding the upgrade.

Was this helpful?