MSD Chemstation won't open - message "in use by another session"

Cannot get MSD Chemstation to open - get a message "Mass Spec is already in use by another session".  Version G1701EA E.02.02.1431 / WIN 10 operating system.  System was shut down temporarily and on startup,  the software does not open.  It is an Agilent 5975MS with a 6890N GC.  Tried rebooting the controller on the MS itself, but that did not work.  Also looked at binding order, but possibly did not do that correctly.  Both MS and GC can be pinged successfully from the PC.  Does anyone know what might be wrong?  Thanks

  • a good question! ;-)


    if you now repeat the powershell command you will see that probably both NICs will now have a value of 25.

    I prefer to manually set the chemical NiCs to a value of (4-)5, because many IT guys do this with their house NiCs.


    NOTE: unfortunately these manual values can get lost:

    1. after a LAN card driver update, or
    2. after Win10 troubleshooting function: reset LAN card
  • Got some help from our IT group.  Evidently there was a problem with the dns suffix which caused Mcaffee to block communication.  Not sure how it got changed but it is working again.  I appreciate your help with this issue...

  • ok that's good to know.  I am going to look into that

  • So they changed each NiC to have automatic metric checked.  Should I manually specify a metric?



  • I ran into this same issue when trying to set up our GCMS computer for network access. For our system the modules were communication on predefined IP addresses (which I found out latter) The pc needed to be at IP under subnet mask in order for chemstation to pass its communication check on opening, otherwise the check would fail and the software would close. I believe by default the system (agilent 7980A GC) is set up this way. When you start chemstation it will ping each IP for the separate modules you have. Take note of what is says the IP addresses for the different modules are. You can check what the actual IP address for each module isFor us (on LAN connection with modules) the IP address for modules are as follows:




    Headspace unit:


      (everything under subnet mask


     * you can check the IP that belongs to the instrument by pressing the "options" button on GC or HS unit and selecting "network". For MS you need to hit "menu" until you get to the "network" selection and hit "item" button to select.



     For me the computer IP got changed when I allowed the PC to automatically obtain an IP address to get network connectivity. I was able to remedy it by doing a windows recovery to before I allowed this IP change (I didn't know what the IP address needed to be at the time or else could have fixed it by manually changing the IP address back to We now have separate network cards (1 for the GC modules and 1 for the network) and therefore 2 different IP addresses on the PC. Even though the correct IP is set for the LAN connection I still have to disconnect the physical ethernet cable for the network when starting chemstation otherwise chemstation defaults to using the network IP for the connectivity check instead of the IP address on the LAN network card connected to the instruments (thus it does not find them and errors out), otherwise I get the error " MS already in use by another session".


    If you have the dynamic IP address option enabled in the instrument modules you are then outside of my scope of experience.


    Good luck!

  • I've run into this problem and there are two fixes. 


    1.  Disable the network card connected to the work network  (or unplug the cable) until the software is started.  Once the software is running, you can re-enable the work LAN.


    We did this on boot-up for about year until an Agilent service tech did something to...


    2.  There is a way in the adapter settings to prioritize the which card the GCMS looks at so this problem goes away.  Sadly, I've forgotten what he did.

Was this helpful?