Struggling with report builder for MassHunter Quant 10

*Edit - report template now attached.


I'm trying to configure a quant report for each sample in report builder for MassHunter Quant 10.


For each compound I want to display the quant MRM on the LHS, then the two qual MRMs then the ISTD on the RHS. 


I've managed to figure out the data binding to get the qualifiers to show up but I am getting the report shown in the picture where each compound shows up twice, with the same wualifier replicated twice on each line.


I've looked through the data bindings for the table the graphics sit in and the bindings for the graphics themselves but can't see how I can differentiate between qualifiers.


I've spoken to Agilent but apart from the very brief overview there doen't seem to be an instruction manual for report builder.


Any help would be greatly appreciated.





 masshunter quant reportbuilder lc-qqq
  • Hi , thanks for replying.


    I'm using Quant 10.1 and Report Builder 10.2.1. 


    Yes that's where I realised I couldn't get any further, because of my data bindings each qualifier is going into its own line and I couldn't think of a way to alter the bindings. I'll try and attach the report template to the original question.

  • Hi ,


    Thanks for your reply. Would you be open to sharing your report template so I could take a look at the bindings?





  • Hi ,


    What is the exact version of quant you are using? Is it 10.0 or 10.1? There are some potential differences even just between those two revisions. 


    What you want to do may be possible, but the bindings will not be trivial, as mentions above. Part of the issue is trying to get two rows of the database table to print in one row of the report, if I'm understanding the issue correctly.


    If you can share your template, or at least the bindings you have so far, it may be possible to come up with something that will work. 

  • Hello strob,

    I had this problem as well when I was trying to create a GCMS multicompound report. I found the issue stemmed from the data bindings. In instances where I had tried to combine "Sample" and "Compound" bindings, I needed to add in a filter to eliminate the overlapping results. I do recall having to do a lot of trial and error because I would change something and then cause an error and report would be mostly empty, or I would end up with duplicates of data and extremely long final report.

    Here is an example:

    The global data binding is for "Sample" and I wanted my table to have results from "Compound" and "SampleChromPeak". I added the following bindings for to the container and labeled the binding "SampleChromNoMod":

    Data name: SampleChrom



    <Top 1>

    My table had bindings for "Compound" and "SampleChromPeak"


    Data name: Compound



    AND <Sample_Key>=<SampleChrom:Sample_Key>



    Data name: SampleChromPeak



    AND <ReportSortOrder>=<Compound:ReportSortOrder>

    For "Top 1" created filter for the key field (ex. Chrom_Key) with the "Top" operator and a fixed value of "1"


    It took me a lot of trial and error a while ago, so unfortunately can't provide more exact information. I couldn't see any clear examples in the data bindings when I opened the template. 


    There are a few people I was able to contact through tech support that work on Masshunter software and they were extremely helpful in trying to figure out what could be causing a given error. As you stated there isn't an actual instruction manual, but with a little programming knowledge and a lot of tinkering I was able to create a report that does everything I was looking to present.


    Another place to look would be using the dropdown list on the right (above where you find data bindings) and change the settings in "GlobalReportProperties1"


    Best of luck!

  • ,


    I apologize for the delay in responding. I didn't get notification of your edit so I only recently saw that you had updated the post with your template.


    A colleague was able to modify your template to list the two qualifiers in each row, rather than having the rows repeat with two copies of the same qualifier on each.
  • Hi 


    Thanks for your reply. 


    I tried that template but got this error when I attempted to generate the report.


Was this helpful?