Thermal Aux 2 - No Sensor for Heater

Hello all,

We are running a GC/MS 5977A/7890B in our lab. Last week, after cleaning and reinstalling our Extract EI source, the system pumped down normally, but the GC gave a "Thermal Shutdown" message. Under status, it read "Thermal Aux 2 Open Sensor" and "Thermal Shutdown". The Thermal Aux 2 is our MSD transferline and the MassHunter software also showed "----" for the Transferline Temperature. I restarted the GC, and got the message "7890 power on with exceptions." After pressing the Aux Temp# button I got the message "No sensor for heater" under Thermal Auxiliary 2 (MSD). I vented the MS again, turned off the MS, GC and PC. I disconnected and reconnected the comm lines hoping (with no good reason) that a cable had been jiggled loose. When I turned everything back on, the conditions were the same. 
The setpoints are correct in the software and on the GC, but the actual temperature is reading 0, and it is cool to the touch. I checked the IP addresses, which all look fine. I pinged the MS and the GC from the PC, and both were successful. 
We have never had problems with this heater and no indications that it was failing. Does anyone have any suggestions? At this point, I am thinking that I probably need to replace the heater/sensor assembly, but I would love to hear other ideas. 
Thank you!  
  • The Mass Spec's transferline heater/sensor is run by the GC. The connections are the four wires with the plug in between labeled "Interface Cable" in the manuals.

    The first easiest thing to do is to turn off the GC power, unplug this connector and plug it back together. Then turn the GC power back on, wait for it to complete it's power on self test, and see if that solved it. 

    If that doesn't fix it, turn off the GC power, unplug this connector, and use a voltmeter to measure the pins on the Mass Spec transferline side. There are two skinny white wires and two thicker wires in diagonal pairs.  The two skinny ones, the Platinum Resistance Thermometer, should measure about 109 ohms at room temperature.  The two thicker wires, the heater, should measure about 17-20 Ohms.   If measuring the two skinny wires reads infinite ohms, the heater/sensor assembly G1099‐60107 will need to be replaced.  The sensor itself is quite fragile when not installed in the proper mounting location. It's a small ceramic cylinder that slides into a drilled hole in the back edge of the heater clamp (that's what the heater block is called). 

    Let us know the solution.

  • Thank you for your reply and your detailed instructions!

    I tried disconnecting and reconnecting the interface, but found no change. When I tested the interface cable with the voltmeter, alas, it appears that we need a new assembly. I got 16.1 Ohms for the thick wires, and 0 Ohms for the skinny wires. Any pro-tips on installing the new assembly without damaging the sensor?

    Thanks again!

  • It's not difficult, just take your time and be careful. This diagram is from the 5977B Series MSD Troubleshooting and Maintenance Manual, page 234. You should NOT remove the transferline off of the MSD to replace the heater/sensor.  Vent, turn off the GC and MS, remove the column, move the MSD away from the GC, unplug the heater/sensor cable, remove the two T20 headed screws that hold the transferline cover to the MS and slide that cover off.

    The insulation is refractory ceramic and, while safe, it is always best to not breathe fibers so wear a mask as you carefully slide that insulation tube off of the transferline, noting the orientation. Then loosen the two screws labeled #8 below and slide the Heater Clamp, #9, off.  You may have to use a flat-blade screwdriver to pry very slightly in the cut on the Heater Clamp to get it loose enough to remove. Loosen setscrew, #3, that holds the heater in.  Then the heater and sensor should slide out of the Heater Clamp.  Slide the new ones in and put it all back together.  The most important thing is to slide the new sensor in very straight. It should slide right in easily.

    If your system has CI capability, there may be one more screw in the Heater Clamp that would have to be fully removed to be able to slide it off of the transferline. 


    DO NOT FORCE anything.  This should all go very easily. Let us know how it went....

Was this helpful?