Hello, I'm new here and having problems with FID Igniting and concentrations of standards and samples are lower than expected. 

I'm using GC Agilent 7890B, GC ran out of air on the weekend, we replace the air tank today as usual and since the FID has problems igniting (unless someone blows on it). Already check for leaks, changed ignition copper washer, cleaned the FID Jet, cooked the column for about 10-15 minutes. After that standards concentrations were low. and FID wont light without blowing

  • Update: Now FID wont light even when you blow on it, tried everything we tried yesterday and even cleaned the FID detector and all that. 

  • Hello  ,

    To troubleshoot an FID not lighting there is an article on it.

    Give that a shot, and if that does not work out, please post a reply with the details.

  • Hi, thankss. We already tried all that, nothing has changed. Just now we even changed the Air tank for a new one, thinking it could be that. 

  • The FID does not ignite, just make loud popping sounds, does not ignite by blowing on it, by putting a flame to it, nothing. We ran out of air on the weekend, (Sunday morning to be exact) (it stays on sleep mode) then on Monday switched to a new tank. At that point FID was starting to have problems but it would still ignite if you blew on it, we ran standards & samples on it and concentrations were lower than expected. After that, we cleaned a lot of things on the FID, trim the column, pretty much did everything that says on that guide. Left it over night on sleep mode, thinking maybe it was going to fix itself somehow by maybe pushing or cooking any water or something... and today the FID does not ignite anymore (not even when you blow on it) .  

  • Update: FID output signal was very low even when trying to ignite, so we checked the interconnect spring and noticed it was shorter than the ones in the other GCs (not that close to the detector base; dont know if it was always like that or something happened to it?), cleaned it with a KIm wipe and wiggle it out a bit so it was closer to the detector base. Ignited the FID again and it worked, ran blank and standard, baseline is funky and has weird peaks (maybe contaminants?). Now the problems is sometimes mid-run FID output signal goes very high and  makes FID flame turn off, but it DOES re-ignite by itself when that happens. 

    I'm not sure if we fixed it and just needs time to get back to normal? or the REAL problem is still there? 

Was this helpful?