OpenLab CDS reports: showing chromatography for analytes both when present or not present

Hello,

I'm trying to report the concentration of analyte using SIM mode. I have built a report that shows a table with the analyte and the ISTD, as well as chromatograms for each.
However, it only shows the analyte in the table (and the resulting chromatogram) when the analyte is present. I would like it to still display the analyte when not present: with zero concentration (and the resulting flat line in the chromatogram).
Does anyone have any ideas?

Using Agilent OpenLab Data Analysis Version 2.5 - Build 2.205.2.34

Thank you,
Rob

  • Hi Rob

    Sounds like you have a group or some report template items that repeat for each compound.  I suspect that this is why, when the compound isn't present, you get nothing.

    Is the report template a Single Injection Report or Single Sequence Summary?  My proper answer will depend on the type of template you are creating!

    /Andy

  • Hi Andy,

    Thanks for the reply! This template is a Single Injection Report.

  • Hi Rob

    If the compound is just missing from the table, then in the table preferences, you should be able to include missing compounds.  I don't understand why the chromatogram would be missing.  Do you have some group that repeats for each compound?

    /Andy

  • Hi Andy,

    Thank you for the response. I found the selection to include missing compounds, but it only seems to show up in the table but not chromatogram. I am attaching example screenshots of what my problem is:

    In Report A, the analyte (1-bromo-2-propanol) is not present, but the ISTD is. In Report B both the analyte and ISTD are present.
    You can see that in Report A, only one chromatogram shows up; whereas in Report B both chromatograms are present.

    My goal is to basically that when 1-bromo-2-propanol is not present, to have a chromatogram with a flat line, showing no peak.

    Thank you,

    Robert

Was this helpful?