Library search settings that work in MicroLab Expert

Hi everyone

We have the Cary 630 FTIR with the Microlab PC and Microlab Expert software products

Many years of using the system still hasn't resolved many of the issues we have encountered. We use other FTIR products that cause far fewer issues than the Microlab products. People avoid using the Cary 630

It came to a head today. I ran an ATR of a known compound (A) and couldn't obtain a library match - fair enough it happens so I made a new library (CHEM) that just contains the spectrum of compound A I ran.

I then ran a library search of my spectrum with several libraries including the new library (CHEM) with just my spectrum in it. Guess what. My spectrum of compound A doesn't match to the spectrum of A in the CHEM library I just created even though it should be identical.

What is going on?

Thanks in advance


Parents Reply Children
  • Hi Kevin

    When you create a new library, you'll see the settings appear in the box where you give the library a name.  If the spectra were collected with ATR then you need to make sure that you've ticked the ATR box, but you can leave the baseline correction tickbox blank.  You also need to select 2 bytes in the Lib Bytes drop down menu and make sure that the "Auto detect from 1st entry" box is ticked.  This will ensure that the spectra you add into the library are added correctly. 

    From the point of view of the search algorithm, the most commonly used one is the "Similarity" option as this scores the matches "closest to 1" which is then easy to understand - for example, if you get a score of 0.95 then that's essentially a 95% match.  The other algorithms score "closest to zero" so it can be a bit more of a challenge to understand if you have a good match or not. 

    I hope this helps.

    Best wishes


  • Hi Robwills,

    When I create a new library using New from the Library menu, I don't have "Lib Bytes". I have a 'Single Byte" option which can be checked or unchecked only. I also don't have "Auto detect from 1st entry" but "Auto Detect" again as a checkbox.

    My version is which could be the problem though for some reason the copyright on the Logo screen says Agilent 2016-2022

    I tried creating a new library and selecting "Auto Detect" and unselecting "Single Byte". Even then when I add my spectra and search the same spectra using the similarity algorithm and my newly created library I only get a 0.65 match which seems low


  • Hi Kevin - thanks for the additional info.  I now realise that you are trying to set up the library in MicroLab Expert software so that explains why you're not seeing the same options that I have described, because I was referring to the base MicroLab software.  Nevertheless, what you've done is correct - by unticking the "single byte" option you've effectively selected the option for 2 bytes and "Auto detect" in ML Expert is the same as "Auto detect from 1st library entry" in the base ML software, so I'm also a little bit puzzled as to why the match score seems low.  When you compare the spectra visually, do they look like a good match?  Is it possible for you to email the spectrum that you want to put into the library and the one you want to compare against it, and then I can take a look myself and see if I can figure out what's going on?  My email address is 

Was this helpful?