TPS-Compact does not reach speed, No display, and cannot communicate with RS232.

My TPS-compact cannot seem to reach its speed, and the pressure is only 8e-3 (it is possible that only roughing pumping is working). The LED is blinking fast; however, the monitor display is not powered on, so I cannot read which error code I am getting. 

Let me describe the symptom upon powering on the pump: when we first turn it on, the pressure goes down to 8e-5 within 10 minutes, and I can see LED blinking slowly. Here, the pressure reading is NOT from FRG-700, which can be hooked up to TPS-compact to get pressure on the monitor. Since the monitor display of the TPS-compact does not work for us, we have installed another pressure gauge. After about 10 minutes, the LED starts blinking faster, and pressure starts rising all the way close to 1e-2. After overnight of running, it reaches 8e-3, which looks like the turbo is not running. Unfortunately, since the display is off, I cannot read the error code.

To read the error code, I have tried communicating with the pump using RS232 using A-Plus software. I am currently using RS232-USB cable and have downloaded the software from here: I am using Windows-11 and have downloaded the 32 bit version. Unfortunately, the software says it cannot find the device. I tried all the baud rates, including and below 9600. Is there any obvious I am doing wrong? Can I still talk to the pump via RS232 even the monitor is off?

Thank you,

Was this helpful?