AnsweredAssumed Answered

MassHunter Crash/Hang

Question asked by reesegar on Jun 13, 2019
Latest reply on Jul 3, 2019 by reesegar

I am currently trying to setup a GC system and am having issues with MassHunter Acquisition.  I am trying to setup a parallel system to one that we are currently running. The new system is  6890N/7697A HS, it does not have a MS. I am trying to use MassHunter to run the system since our other system is 7890B/7697A/5977A and would like to keep the same workflow for acquisition and data analysis. I have been working with Agilent to find the cause but thought someone in the community might have seen this issue before and could help also.

 

Information for the system:

6890N version: N.06.07

7697A version: A.01.06

MH Aq version: B.07.05.2479  23-Aug-2016

PC: HP Z220

OS: Win 7 (x64) Pro Service pack 1

RAM:20GB

excel installed

MS Qual version: B.07.00

MS Quant version: B.08.00

Connections Setup (Local connection): PC => switch => HS/GC

 

The MHInstall.LOG file has an error, but IQTools system verification tool shows all PASS except for MassHunter Aquisition GCRC.dll, which is an installed "patch" I received from Agilent so that the 6890N FID signal was saved correctly. Below is the error and the invalid file.

 

MHinstall.LOG Error:

“InstallShield 16:52:12: Error extracting ISBEW64.exe from ISRegSvr.dll”  

 

Invalid Files :
Full Path                                Installed Version              Expected Version              Reason
C:\GCMS\msexe\gcrc.dll      7.5.1.12                            7.5.0.2479                         Checksum Mismatch,Version Mismatch

 

Below are a list of things that I noticed in the software and on the instruments when the error occurs.

 

1.    The mslogbook does not show any connection errors. When the error occurs it does not have any entries, passed the time of the crash, until I restart MassHunter Acquisition.

2.   The headspace and GC do not seem to notice that MassHunter Acquisition has crashed.  If I do not select "close program" in the Windows error window, they both complete all of the runs in the sequence that was running when the software crashed. For example last night it crashed after 25 vials, I watched the GC and Headspace complete the sequence with vial 66 when I got in this morning and neither showed an error.

3.   The GC "remote" light stays ON even after the software crashes. When I restarted MassHunter Acquisition the "remote" light flashes off then back on quickly when Acquisition loads and is initializing the instruments.

4.   The GC shows "signal 1 buffer full", but this is only after I finally select "close program" in the Windows error window.

 

Below is a list of things that I have tried to resolve the issue.

 

1.   Tried both NIC cards on the PC in case it was a connection issue.  It doesn't seem to act like a connection issue since the MassHunter logbook does not show a lost connection.    

2.   Created new sequences from "default" sequence.

3.   Re-Created acquisition method from "default" method.

4.   Ran "repair install" from MassHunter installation disk.

5.   Un-installed/Re-installed MassHunter following installation instruction located on the install disk. Renamed old MassHunter folders to .OLD before re-installing MassHunter.

6.   Re-installed MassHunter again this time using the PC recovery disk included to start with the initial "clean" image of the PC before re-installing MassHunter. 

7.  Verified multiple settings and system files in the operating system

 

Are there any ideas on resolving this issue? I am running out of ideas to try and am thinking my next solution would be to uninstall MassHunter and run the system using Open Lab CDS Chemstation Workstation and changing my workflow and my LIMS workflow.

 

Below is the Windows error that keeps occurring during a sequence. This error does not happen consistently, I see the error after 96 vials, 1 vial, 25 vials, 9 vials etc. The error does not occur at the same "Time of Day".

 

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: msinsctl.exe
Problem Signature 02: 7.5.0.2479
Problem Signature 03: 57bccd24
Problem Signature 04: mscorlib
Problem Signature 05: 4.7.3062.0
Problem Signature 06: 5ab95126
Problem Signature 07: 331
Problem Signature 08: 10
Problem Signature 09: System.ArgumentException
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

 

At the same time the above error occurs there is a .Net error created in the Windows system logs, shown below.

 

EventData:

Application: msinsctl.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.ArgumentException at System.ThrowHelper.ThrowArgumentException(System.ExceptionResource) at System.Collections.Generic.Dictionary`2[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].Insert(System.__Canon, System.__Canon, Boolean) at Agilent.Analytical.GC68xx.RCWrapper.Reporting.ReportType.GetParameterDictionary() at Agilent.Analytical.GC68xx.RCWrapper.RCProcessIF.GetIcfResourceProperty(System.String, Agilent.RapidControl.KeyValueInterfaces.IRCKeyValue ByRef) at Agilent.Analytical.GC68xx.RCWrapper.RCProcessIF.GetResourceProperty(System.String, Agilent.RapidControl.KeyValueInterfaces.IRCKeyValue ByRef) at HIA.GC68XX.GCGetPostRun() at HIA.GCRC.GET_RUN_LENGTH(Boolean ByRef) at HIA.Runctl.UpdateRunTime(Agilent.MassSpectrometry.CommandProcessor, Boolean) at HIA.Runctl.runClock_Tick(System.Object) at System.Threading.TimerQueueTimer.CallCallbackInContext(System.Object) at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.TimerQueueTimer.CallCallback() at System.Threading.TimerQueueTimer.Fire() at System.Threading.TimerQueue.FireNextTimers() at System.Threading.TimerQueue.AppDomainTimerCallback(Int32)

 

 

 

Thanks in advance for any help and ideas

Outcomes