0 Replies Latest reply on Aug 6, 2018 10:17 AM by fomalhaut

    Communication problems with 5973N MSD

    fomalhaut

      This is probably not a new problem but I can find no other posts or answers related.

       

      I am having difficulty setting up the following Agilent MSD system:

       

      5973N MSD, model G2577A, Ser # US44647275, current firmware 5.01.63, original was 5.01.73 (see below)

      6890N GC, model G1530N, ser # US10508008, firmware N.06.07

      PC, Dell Optiplex 745, Windows XP sp2, 4GB ram, 500 GB HD, (also tried on another PC running W2K with same results)

      Software version G1701DA, Rev D.01.00

       

      This system was acquired second hand from another lab and had not been in operation for several months. This Chemstation D.01.00 software is the only one available and presumably had been used on this system.  Original PC not available.

       

      The instruments were connected using a 6 port hub.  I installed the Chemstation software under XP including Agilent BootP and Agilent IO libraries from the disc.  I configured the system under msconfig.exe and set BootP for the correct settings to match each instrument: MS IP 10.1.1.101, GC IP 10.1.1.102 and PC network card IP 10.1.1.100. I set both instruments IP manually, rebooted the MS with the new network settings. DHCP is disabled as this is set up as an isolated network.  Once setup originally, the system came up just fine and I was able to acquire gcms data files.  I shut down the system for a while and when I tried to run it again I started getting errors.

       

      Here is the scenario I observe:

       

      When I start by clicking the Instrument #1 icon, mstop.exe opens and recognizes the configured IP addresses of both MS and GC.  It then goes into “Synchronizing…” and opens msinctl.exe which then opens up a blank DOS type window for msinctl and eventually locks up with an error msg box labeled MSINCTL  “unable bring the MS on line, error 204”.  If I click the OK button it just repeats the process.  I can stop the cycle and recover by stopping the processes msinctl.exe and then mstop.exe.

       

      Before I start the software, I confirm that I can ping both instruments IP’s successfully but using the 5973N panel I cannot ping either Chemstation or the GC.

       

      One thing that did occur when the software was originally working was that when msincntl.exe started I would get a message box which said that MSD firmware version 5.01.63 was expected but version 5.01.73 was found.  When I clicked OK or proceed, then the system would come up OK and run fine.  I decided to try changing the MSD firmware using the included program on the disc.  It completed successfully but in fact it downgraded the firmware to 5.01.63. There was no other option.  I can’t recall but I suspect that these error problems started occurring after the MSD firmware was downgraded.  Perhaps the downgraded version doesn’t match up with the Chemstation software version D.01.00 that is installed. I get no errors related to that however.

       

      I can’t find any way to independently upgrade the 5973N firmware on the Agilent website whereas I can find upgrade paths for the 6890GC firmware.  I have another system consisting of a 5977 MSD and 7890GC running under MassHunter.  I have been told MassHunter will run some 5973N-6890N systems and will be able to upgrade 5973N firmware accordingly but I can find no other way to upgrade 5973 firmware unless I could perhaps acquire a newer Chemstation license.

       

      Any assistance with this problem is deeply appreciated.