9 Replies Latest reply on May 23, 2018 9:04 AM by ryoboyle

    Intelligent Reports

    myrian

      Hello:

       

      I am using Open Lab CDS C.01.05[35}

      There are several things I would like to be able to do.

       

      I am using a Seq. Summary Report Extended and I have added a column to the Percent Area Report to provide Concentration.

      Is there a way I can add another column that will provide % concentration (similar to Area %)?

      Using the Percent Area Report is there a way to sum all peaks before a main peak and sum all peaks after the main peak?

       

      Thanks,

        • Re: Intelligent Reports
          ryoboyle

          Hello,

           

          I added tags to your post to increase visibility.

           

          The simplest way to get a report to calculate a % concentration value similar to Area% is to update your Quantitation Settings (accessed by going to Report > Specify Report) and change the calculation mode to Normalized Percent, as seen below:

           

           

          If you change the Calculation Mode to Norm%, the value then displayed in the Amount column on your report will be the Normalized % amount. For your reference, below is the equation used to calculate Normalized %:

           

           

          To sum only certain peaks together while still wanting to display individual results for these peaks, one solution would be to create compound groups for the compounds before the main peak and after the main peak. You can then report the results of the compound groups in a separate table.

           

          You could also create a series of hidden fields where you assign variables to each peak/compound's area/amount (depending on what you want to sum). You could then sum these variables in a custom field.

          1 person found this helpful
            • Re: Intelligent Reports
              myrian

              Thanks for your reply.

               

              I was able to get the % for each peak.

              I also set up 2 groups by going to the calibration table (group1 before main peak, group2 after)

              Now I don't know how to display the sum results for group 1 and sum for group 2.

               

               

              Thanks,

                • Re: Intelligent Reports
                  ryoboyle

                  Check the Area Percent table properties on the SequenceSummary_Extended report template. When I look at it on my C.01.05 install, there are the below filters set up:

                   

                  If you take a look in the Report Template Editor Concepts Guide (https://www.agilent.com/cs/library/usermanuals/public/RTEConceptsGuide.pdf ), there is an appendix starting on page 175 on Enumerations. Below is a table from this appendix outlining CompoundType enumeration:

                   

                  As you can see, a Compound Group is defined on by the report editor as a Compound_Type = 4. The default filter on the Area Percent table is set to display results for all compound groups except PeakSums and Groups. If the filters on your report are still set to the default, this would explain why your group results are not being reported. You can fix this by deleting the Compound_Type <> 4 filter.

                  1 person found this helpful
                    • Re: Intelligent Reports
                      michalab

                      Hi ryoboyle,

                      I am able to get the groups organized in the calibration table and in the Intelligent Reporting, and by selecting Norm% I can see the amount reported as percentages. Is there a way to maintain the percentage (in column 'Amount') in the table on the left (below) and report the 'Total (µg)' for the groups in the table on the right in their actual µg value (not in percentage) in the same report ?

                      IR.jpg

                        • Re: Intelligent Reports
                          ryoboyle

                          Hi michalab,

                           

                          In order to achieve this you need to switch back to a Calculation Mode of ESTD. You would then need to define an aggregator that you can use to sum the calculated amounts of all of your compounds so you can call it in a custom calculation.

                           

                          To define the aggregator, you can create a new table that contains only the compound amounts in it. You can then edit the amount column's value properties to save the expression result as an Aggregator (see below screenshot for guidance).

                           

                           

                          You can then hide this table from view on your report by going into the table's Advanced Properties and un-checking the 'Visible' checkbox:

                           

                           

                          With the table hidden, you can resize it as small as you can make it so you do not lose any space on your report template. Just make sure that the hidden table is above your compound results table.

                           

                          With the aggregator defined, you can then add a column in your results table for the Norm% Amount as seen below:

                           

                           

                          Hopefully this helps.

                          1 person found this helpful
                            • Re: Intelligent Reports
                              michalab

                              Hi ryoboyle

                              I'm putting the finishing touches on the report here and I'm not sure how but my Values for one of my columns isn't displaying. In the picture I attached in my previous comment, you'll see two tables. On the table on the right, the column 'Group Name' isn't displaying the names of the three groups. The column on the right of the same table ('%') remains unchanged.
                              The table we're talking about is called Table_PeakResults1The value in the 'Group Name' column is =Compound_GroupName
                              The Filtering is set to '=Compound_Type'  '>='  '=4'
                              The selected Filter on Peak Types are : Identified Peaks, Compounds Used for quantitation, and Unknown Peaks
                              Grouping is set to Grouping_2 and the value is =Compound_GroupName

                               

                              I even checked to make sure my font color was set to black to make sure it wasn't displaying white text on a white background.
                              I tried playing with the Filtering instead of '>=' I also tried =, <>, <=
                              I've also tried to delete the table, drag a new one in, and set it all up again.

                               

                              Do you know why I'm not seeing these values anymore?
                              The picture I attached in the previous comment was from an old rev of the same report.

                               

                              Thank you