3 Replies Latest reply on Mar 22, 2018 10:00 AM by ryoboyle

    OpenLAB CDS not automatically printing reports

    fictorie

      I am running OpenLAB CDS 2.2 with an Infinity II 1260 LC.  The system is new and I am to both OpenLAB.  I have a processing method (built from scratch) prepared that includes a report.  When I manually process data, I can manually print the report with no difficulty to the default network printer using the toolbar.  I have the processing method set up to automatically generate a report and save a pdf and send it to the same printer (under Injection Report in the Processing Method).  I select this processing method when I set up the single injection or a sequence in Data Acquisition.  The goal is that the sequence generates printouts for each sample in the sequence (i.e. run overnight and print reports to pick up in the morning).  The sequence and the single injection, when run, will automatically produce the pdfs, but will not print. 

      • I have turned off (checked the box) in the Project Options in Control Panel that allows printing of unsaved processing results.
      • I have the network printer set as the default printer in Windows and in Data Acquisition (via the File tab).  I don't see other places where default printers can be identified.
      • Reprocessing data manually after-the-fact does not automatically produce a new pdf nor does it print.  However, the print checkbox is selected/on in the processing method even after reloading both data and processing method.
      • I've rebooted the individual modules, control panel, and the computer with no improvement.

      Any suggestions or things that I am missing?

        • Re: OpenLAB CDS not automatically printing reports
          ryoboyle

          I added tags to this post to increase visibility.

           

          If you are unable to print automatically to a networked printer, then you might need to provide domain logon credentials to the Agilent OpenLAB Instrument Service. To access the service properties, search for the word 'Services' in the Windows search bar and launch the Services desktop app from the search results. In the Services window, you should see an Agilent OpenLAB Instrument Services:

           

           

          Right-click on the Agilent OpenLAB Instrument Service and select Properties in the right-click action menu. This will pull up a Service Properties window with multiple tabs. Go to the Log On tab and the default setting is to "Log on as: Local System account" as seen below:

           

           

          Change the "Log on as" setting to "This account" and then click on the "Browse..." button. This will pull up a Select User window. Input a domain username with access to the network printer into the text field at the bottom of this window and then click on the "Check Names" button to format the username in the correct syntax. Then click "OK"

           

           

          You will then need to provide the password for this user and confirm the password. Then click on "Apply" and "OK":

           

           

          Once you have made this change to the service properties, restart your PC and you should hopefully then be able to print reports automatically.