OpenLAB CDS not automatically printing reports

I am running OpenLAB CDS 2.2 with an Infinity II 1260 LC.  The system is new and I am to both OpenLAB.  I have a processing method (built from scratch) prepared that includes a report.  When I manually process data, I can manually print the report with no difficulty to the default network printer using the toolbar.  I have the processing method set up to automatically generate a report and save a pdf and send it to the same printer (under Injection Report in the Processing Method).  I select this processing method when I set up the single injection or a sequence in Data Acquisition.  The goal is that the sequence generates printouts for each sample in the sequence (i.e. run overnight and print reports to pick up in the morning).  The sequence and the single injection, when run, will automatically produce the pdfs, but will not print. 

  • I have turned off (checked the box) in the Project Options in Control Panel that allows printing of unsaved processing results.
  • I have the network printer set as the default printer in Windows and in Data Acquisition (via the File tab).  I don't see other places where default printers can be identified.
  • Reprocessing data manually after-the-fact does not automatically produce a new pdf nor does it print.  However, the print checkbox is selected/on in the processing method even after reloading both data and processing method.
  • I've rebooted the individual modules, control panel, and the computer with no improvement.

Any suggestions or things that I am missing?

  • Hi Ryo,


    I had a default printer that was working fine until one day it stopped auto printing. (I do not recall making any changes to the workstation). It still prints if I manually click the print button.


    I tried

    1. auto printing from the admin windows login using "Local System Account"

         (status changed to "completed" without auto printing. No reports were printed even when "create report" lines were added to the sequence)

    2. auto printing after changing instrument services to the admin windows account

         ( run status changed to "processing" at the end of the run and other runs cannot be initiated. the run status remained as "processing" and could only be reseted when the workstation is rebooted)

    3. auto printing after changing instrument services to the standard user windows account

         (clicked launch project, after a long wait "unable to connect to instrument server" message shows up)


    Please help us




  • Hello Wayne,


    You might want to remove and re-add the printer in Windows from scratch so that you are starting from a clean slate.


    Below are the valid instructions from the Workstation Installation Guide ( ):


    Make sure that you are logged into Windows as the service user (who is also an admin) when you add/configure the printer in Windows and then set the printer as that user's default printer as specified in step 3.

  • Hi,

    It worked!

    I reinstalled the printer from admin, remained using Local System account, and made sure the Instrument Service was "started" before running sample acquisition.




Reply Children
Was this helpful?