Library Editor won't accept spectra

Hi all,

I'm working on creating a library using the library editor application and have run into a snag copying over spectra. 

I copy the spectra to my clipboard, and go to paste it with the relevant compound selected in library editor in the spectrum view tab. When I do this, and error pops up stating "There is an error in XML document (1, 403). Any ideas what is the cause or if I am missing something? 

  • Hello  ,

    What version of the Library Editor are you using? And where are you tying to copy the spectra from? Copying from qual and the editor itself should work. In some versions there are issues if the number of decimal places in the copied spectra are set to one or no decimal places, but I don't recall seeing this exact error.

  • Hi,

    I'm using version 10.0 and copying from MassHunter qual 10.0 as well. I've adjusted the decimal places to two but am still having the error pop up. I tried copying over the specific spectra to the demo library and still have the same error so I think you're on the right track that it's probably a setting that is incorrect in qual, I just have no idea what it is Sweat smile

  • HI

    follow this steps 

    First you need to create new compound 

    then right click you cmp and select new spectrum .

    now you need to add spectrum from your dataanlysis .

    note : Library editor is related to Quantitative software not Qualitative

    now open your compound in Data analysis . every compound whether it is Scan , SIM or MRM has a spectrum , select this open this spectrum

    right click on spectrum and select copy

     then paste it in spectrum in library editor , 

    library editor will get all the information about the compound in this way , you only need to add name and CAS number and Formula



    note : Library help Manual comes with Quant soft , search for it , every single step is written

    this is some screenshots :

  •  and  ,

    While the Library Editor is part of the quant package, it does support pasting of copied spectrum from both qual and quant. You can also have more than one copy of the Library Editor open and copy and paste spectrum from other libraries. It does not support pasting from Unknowns Analysis or from the NIST MS Search program. If you copy spectrum from an unsupported source you should either get no Paste option or, if there is a Paste option, nothing will happen.

    I believe I may have been able to duplicate your issue. If I change my region settings to use the comma (,) as a decimal symbol I receive the following error when pasting spectrum.

    Please try changing your Decimal symbol to a period (.) and see if that resolves your issue. This can be done in the control panel in the Region settings and then under Additional settings...

Was this helpful?