Blank subtraction and peak tags for Masshunter Qualitative and Quantitative software

Hello all.

We just got a new GC-MS and it uses the Masshunter software for the processing the results.

We have an analysis run of 27 compounds, so when I'm processing the spectra in Masshunter Qualitative, it's hard to always remember which peak is in that exact RT, specially when you have more than one peak close together. So I wanted to add labels to all peaks according to RT. I was able to find how to manually add comments/labels but that would mean that I had to do it for each and all samples processed. Is there a way to program it to automatically add the labels to all spectra that I open with the software ?

For the quantitative analysis:

I tried a test run consisting of only a blank, a QC run as QC, and the same vial run as sample. When processing the results I saw that, although i had responses in the blank, the software was not subtracting that amount from the samples when giving the final concentration. How can I set it up so it does? I tried to use the custom calculation column, but could not find a way to define the calculation steps.

I appreciate any help.

  • Hello ,

    By default, in Compound View, if you click on a compound, its label will appear on the compound chromatogram and the spectrum will be labeled with the compound name as well as the structure, if available. Depending on the length of your compound name you may want to enable label overlap in Chromatogram Display Options, and/or turn on vertical labels.

    If you are not observing this you can reset Qual to defaults by exiting Qual, going to the Start menu and finding the Agilent MassHunter Qualitative group, then Tools for Qualitative Analysis 10.0, and then running Restore Qual Settings.

    Let me know if doesn’t help with the issue you are having.

    For blank subtraction in quant the simplest and most common method is to use the Quantitate with Blank Subtraction Add-in. You can activate this by going to the Tools->Add-ins menu item and enabling the Add-in.

    Then in batch view go to the Add-Ins tab and run the Add-In. It will put the results in the Custom Calc. field for samples.

  • Thank you for the help Howard!!

    I was able to use the compound viewer, but in the workflow if I just select our library it will only label the RT and not the compound name by some reason. If I also select the NIST20 library it will label the names but for some compounds it will label it with the wrong name. But its better than nothing, thank you.

    I found the Add-ins tab but for our program we only have run query add-in and sample/compound group navigation. where can I find the add-in that you mention?

    Thank once again and sorry for the trouble.

  • ,

    If your library has very long names and you are not allowing labels to overlap, then you may observe this. Make certain you have Vertical labels and Allow overlap with other labels enabled in Chromatogram Display Options and see if that allows for the compound names to be displayed.

    There are a few things you can look at if the wrong match is being displayed. If you want to make certain that searching primarily uses your library, try lowering the Score setting for your library and have it Stop at first library / database match.

    You can also manually adjust which hit is selected in the Compound Identification Results window. By default this is tabbed with the Method Editor and may not be immediately apparent. This can be useful for isomers if you have other information and know which one is present in your sample.

    For the quant blank subtraction add-in, if it is not present you will need to add it to quant by going to the Windows Control Panel->Programs and Features. Select the entry for Quantitative Analysis and choose Change. Click on the Change button in Maintenance. On the next screen enable the Bank Subtraction Add-in and any others you want to add. Click through with Next and then click Modify to update your installation. When you start Quant again you should now have any Add-ins you selected available for use.

  • Thank you very much Howard,

    I was able to install the add-in.

    Thanks for the help

Was this helpful?