Reporting all of a sudden stopped working for MH Quant 10.0 software

The reporting on our MassHunter Quantitative Analysis software (10.0, Build 10.0.707.0) is no longer working. We haven't changed anything on the software. The reporting stops before even creating the report.xml file and is issuing an error message (Error: 56;67;80 is not a valid value for Int32). The reporting works just fine on the Unknown software on the same computer (Windows 10 64-bit). The report method is working on our second Agilent system. The Quant software is the same on both systems. The regional setting of the PC is correct. Re-installation of Quant did not help. The Repair Tool for the Quant Reporting did not help either.

Also, the Software Verification Tool is not showing any software components but shows the error 'cannot be an empty string Parameter name: productCode'.

Our local support says the only way to go forward is to re-install everything. This is not an option for us, as we have Maestro installed on top. Also, the system was working 3 years just fine.

How can this be solved? Anyone else having the same problem?

Reporting-Log:
2541.QuantReportMethodRun-20210419-183121-860.zip

Top Replies

  • Hello ,

    I have not seen this exact error, but the numbers reminded me of an RGB color value. Sure enough, if you edit the reporting method, go to the Graphic settings tab and then go to Sample chromatograms…

  • Hello ,

    I have not seen this exact error, but the numbers reminded me of an RGB color value. Sure enough, if you edit the reporting method, go to the Graphic settings tab and then go to Sample chromatograms Graphics settings... those numbers are the RGB values for the default TIC color Dark Navy. You have to click the drop down, scroll to More colors... and then Define Custom Colors >> to see this.

    This could be an issue with the Report Method or the user preferences.

    I would suggest trying the following.

    First close all open copies of Quant and Unknowns Analysis. Then go to the start menu, find the Agilent MassHunter Quantitative program group and then find Quantitative Analysis Tools. This will open a folder of shortcuts. One of them should be Restore User Settings. This will clear all user preferences, including window and column layouts. Run this short cut and type y to proceed.

    Then I would open one of the demo data batches that shipped with Quant. I like using the TQ data for the Drugs of Abuse batch since it is small. Then make a new reporting method and use one of the default shipping template and see if the report generation is successful. 

  • This worked! You made my day!

    I restored the user settings using the Tool 'Restore User Settings', reopened one of my batches and the reporting worked with a default template. (Choosing one sample and one analyte only also yields a speedy reporting ;-) also, I had not installed the demo data batches...) The 'old' report method did not work, but writing a new report method did help and reporting (pdf and xls) is now working as before.

    Thank you very much for your help!

Was this helpful?