Which rough pump should I buy for a 6495 TQ, if I need a replacement?

Hi,

Are there any upgrades or updates to the humble rough pump?
I will be needing a replacement, as there is mystery leak escaping the catch tray. 

Thanks in advance,

Zsuzsi

Parents
  • Hi Zsuzsi,

    The Pump part number is G1960-80040

    The MS40+ pump is used on the 6495A and 6495B TQ instruments and is still the current rough pump on most Agilent LCMS.

    If the leak is coming from somewhere in the body of the pump, with oil gathering in the tray below and it is not resolved by tightening the obvious screws, it is probably worth changing the pump. In the meantime keep it topped up with oil  6040-1444. You must vent the instrument and follow the instructions in the maintenance guide. The oil has changed over the years and this is the current one for the MS40+ pump.

    It is also possible that oil is being lost via the exhaust. Typically you will see the oil level drop, but not see oil gather in the tray below. You may also notice visible mist from the pump exhaust. This could be an internal issue with the pump and replacement would be the best option. It could also be a mist filter that needs changing G1960-80039. Again, the maintenance guide in the TQ resources shows how to change this item.

    As always contact your local Agilent Customer service team if you need assistance diagnosing the issue.

  • Thank you Ross.
    That's exactly the information I was looking for.  

    Unfortunately most of the oil escapes the collection tray, although some also accumulates there.
    I haven't been able to pinpoint where the leak is, but it must somehow be at the side of the pump. We recently had a PM, and it is otherwise in good condition.

    Thank you for taking the time to respond.
    Really appreciate it.  

Reply
  • Thank you Ross.
    That's exactly the information I was looking for.  

    Unfortunately most of the oil escapes the collection tray, although some also accumulates there.
    I haven't been able to pinpoint where the leak is, but it must somehow be at the side of the pump. We recently had a PM, and it is otherwise in good condition.

    Thank you for taking the time to respond.
    Really appreciate it.  

Children
  • You are very welcome Zsuzsi,

    If it has only started to loose oil after the PM follow up with your local Customer service or engineer to rule out the mist filter.

    These are replaced at PM sometimes we get a bad one and replacing it can resolve oil loss if it is being lost through the exhaust.

Was this helpful?