Agilent 7000A - MS Error 1.5

Dear colleagues!

Suddenly the new problem with our Agilent 7000A has appeared

Instrument has worked quite intensively for a year in our laboratory (instrument has been bought refurbished 20 month ago).
A month ago, during the analysis process, error 1.5 "Entrance lens driver cannot maintain the requested voltage" began to appear. After some time, the error is cleared and several tens of seconds it is OK, and then the same error 1.5 appears again.
At the same time the high vacuum sensor begins to give overestimated readings: normally the vacuum is ~ 5x10e-5 Torr, and at the moment when an error appears, the sensor gives 10e-8 - 10e-10 Torr on the MS display, and Mass Hunter shows only ---. When everything comes back to normal operation, the readings on the MS display and in the MH become equal and have the order of 5x10e-5
When we tried to make a ramp in Manual Tune (Ion source/Entrance lens), there was no power to the filaments. This coincided in time with incorrect readings of the high vacuum sensor. When the high vacuum sensor readings became normal, the ramp was acquired normally

What has been done:
1). Ion source has been cleaned
2). Filaments were replaced (the old ones looked good).
3). Checked the contacts of the ion source board
4). Checked lens-body short circuit - OK
5). Wires and pins - OK
6). There is no shorts between pins and body
7). Sideboards were cleaned with compressed air and vacuum cleaner (there was quite a lot of dust)

According to the service engineer, the problem was the high vacuum sensor. The high vacuum sensor gives incorrect readings that are outside the acceptable range, and the protection system turns off the power of the ion source - hence the error 1.5 (electrical supply - Entrance lens.

The high vacuum sensor has been ordered and replaced. For about five minutes after starting the MS (turbine at 100%) the high vacuum values were normal. At this moment, we acquired correct IS/Entrance lens ramp in Manual Tune and after that error 1.5 "Entrance lens driver cannot maintain the requested voltage" appeared again, the readings of the high vacuum sensor went to the 10e-8 - 10e-10 Torr unrealistic range.

Analyzing LogBook we also revealed that along with error 1.5 an error 5.1 “Firmware DSP error” also appeared periodically


What could be source of the malfunction? What else can be diagnosed?

  • Hi Mag,

    Thanks for the detailed post. The firmware DSP error concerns me.There seems to be a couple issues going on with the instrument, that I would suggest having your service engineer revisit. I think advice from the community at this point may delay resolution as the instrument may need troubleshooting of the electronics module.



  • Hi,


    10e-8 - 10e-10 Torr often means the vacuum gauge is off, this could be caused by the error state of the instrument. Most times fault 1.5 is caused by multiple other faults on the instrument and has no own issue.

    As James told you there is a problem with the electronics (I guess ion source PCA or main board).

    Please call the Agilent customer service center to get an onsite asap.



  • Hi Mag,

    Were you able to rectify your issue?





  • Hi,


    sometimes the error 5.1 is caused by corrupt method or sequence files. i.e. if you copied your method from another instrument, please try to create a new one from the default method.

    This error could also be caused by damaged firmware, try to reinstall or upgrade the FW of the QQQ. You can also try to repair the Massshunter ACQ from the CD or USB.


    There are also some cases where this fault caused by a broken SmartCard and/or PLX board. If you already tried all tipps above, please call the Agilent service.




  • Thank you for all the info in the post.


    I have seen driver errors like that before. In my experience it is caused by a short some where in the ion source. There isn't really enough space for the extractor lens (brown) wire and post so if either piece is touching another bit of metal you'll have a short. We shaved down our extractor lens post because it was such a persistent problem on our 7000B.


    I am now having that 5.1 firmware issue you mentioned on my 7000C. I get through about 2 injections before that error pops up. Did you ever find a fix for the 5.1 firmware error?




Was this helpful?