Help getting OpenLabs CDS open - freezing on startup macros

When I try to open OpenLabs CDS (online version), it is freezing on "Initializing: Startup Macros".  I have restarted the GC and the computer multiple times, no change.  It is an Agilent 6890 with 7683B injector.  Any tips are appreciated!

Top Replies

  • Hi  

    This problem occurs when the power off suddenly in you lab or when the power is unstable and this causes corrupt to online config file,so to solve this problem just change config file.

    In old version from C drive go to folder chem32 than open the instrument number folder (1 or 2,3...) look for file CONFIG rename to CONFIG.old this reg will be recreated after restart .see example below




    And for new version from C than folder  Program Data than folder Agilent Technologes than folder chemstation than folder instrument  number(1 or 2,3..) than look for file CONFIG .REG rename to CONFIG.REG.old




  • Hello,


    As recommended, resetting the instrument's config files is a good place to start. On top of the config.reg file, I would also recommend resetting all of the files outlined in the following link (in C.01.09 these files are found in C:\ProgramData\Agilent Technologies\ChemStation\#\ where # is the instrument number):Autostart macro failed error 999 in OpenLAB CDS ChemStation 


    If resetting the config files does not resolve the problem, the next thing to check would be if you are specifying any custom macros to be initialized upon startup. Check in C:\Program Files (x86)\Agilent Technologies\ChemStation\CORE to see if there is a user.mac file present. If so, try renaming this file to user.old and seeing if you can then launch ChemStation. If you can, then it would indicate that a macro or command specified in the user.mac file is running into problems. 

  • Thanks and .

    I renamed the 4 files (config.reg, ChemStationPerInstrumentSettings.config, instrument.config, RapidControl.InstrumentConfig.xml). I do not have a user.mac file in the CORE folder.

    The program opened once and I reconnected to the GC.  However, when I try to close and reopen the program, I am now seeing a new error "Launching failed.  Value cannot be null. Parameter name: Command line argument of ChemMain process is empty".  The program freezes as soon as the window opens, before reaching the Startup Macros dialog.  Any ideas?


    I have also noticed that whenever I try to restart my computer, it says that process "CAG Server Executable (32-bit)" is preventing restart.

  • Hello,


    I would recommend that you run the Software Verification Tool (available under Start>Agilent Technologies) to qualify your installation. Make sure that all of the SV Reports that are generate come back with an overall status of Pass.

  • Hi,

    All of the SV reports have an overall status of pass and did not find any


  • Try creating a new instrument in the OpenLab Control Panel (configured for the same instrument hardware) and see if you get the same error. This will help determine if the problem is instrument specific or is impacting the software installation as a whole. 

  • Hi  

    You can try  repairing your OpenLab CDS system,this can  repair installations that are broken due to corrupted or missing files.

  • I created a new instrument in the Control Panel and it produces the same error.

  • At this point I can only think of the below recommendations:


    • If applicable, verify that your Antivirus program is configured with the exclusions outlined in the Post-Installation Tasks section of the WorkStation Installation Guide. 
    • Run a repair on the installation using the installation media
    • If you are still unable to launch ChemStation, then you might need to uninstall and reinstall the software. 


    For more in depth troubleshooting, I would recommend that you contact Agilent support directly: 

  • I have had this issue with the Offline version, It's pretty frustrating and one Agilent representative told me to do a fresh installation but that takes too much time and i not worth it. 

Was this helpful?