Openlab 2.4 with ECM - "OS Owner"

Hi!

What does the ECM's OS Owner colum show to us? In some of the projects, every result set's owner is "builtin/Administrators" but sometimes it's a real person/Analyst. Why? I've noticed that, in some resultsets owned by a real person the user defined keys are missing. Since this, the resultset can not be opened from CDS anymore. How can that happen? The result sets without any injections in it has no user keys, but somettimes they lost them with many many injections, so it means data loss.. Disappointed  They keyless relsultsets are visible in ECM, i can open the ssizp, but if you want to open it in CDS, nothing in there just an error message, and a 0001.01.01  01:01:01 injection time Disappointed

Is there any GMP way to fix these files, maybe convert the ssizip to olax format, and import back to its original place?

Thx,

Peter

Parents
  • Peter,

    The most likely cause is someone copied data in ECM by retrieving and upload the data back into ECM. This will not work with CDS data as the metadata is lost. CDS result sets must be upload through the CDS 2.x client. You should be able to check this by looking at the ssizip files audit trails. If this is not the cause then you will need to open a support ticket with your local informatics software support team. You can do this at the Agilent Software Service Desk.

    Thanks

  • Hi!

    These files were not moved in any way. Just simply lost they keys Disappointed  (sometimes the same happens if you take many snapshots, OL lost the injections after the last snapshot or even the full sequence, but ECM can see the whole thing) Is available a rekey tool that can fix the files within the ecm? :)  (our serviceguy mentioned a small app which capable to repair the missing keys, but we have to extract the ssizip out of the validated enviroment, then import back to CDS. It's not too GMP for me.

    Peter

Reply
  • Hi!

    These files were not moved in any way. Just simply lost they keys Disappointed  (sometimes the same happens if you take many snapshots, OL lost the injections after the last snapshot or even the full sequence, but ECM can see the whole thing) Is available a rekey tool that can fix the files within the ecm? :)  (our serviceguy mentioned a small app which capable to repair the missing keys, but we have to extract the ssizip out of the validated enviroment, then import back to CDS. It's not too GMP for me.

    Peter

Children
  • Peter,

    I have not heard of any tools to rekey the ECM metadata for CDS. What you are missing are not the normal ECM filter keys so a standard ECM rekey will not resolve. From the original post it seems you are missing the CDS 2.x custom key that is written by CDS ACQ or DA when it uploads data to ECM. The service rep may be referring to another issue. If this is happening regularly you should open a ticket so the informatics team can look into the issue. 

    Marty Adams

  • It happened again today. We've lost a fully finished analysis. Ticket is sent to the  local agilent service, but they cant say any promising things..

    :(

  • Hello, Please put in a ticket online at servicedesk.li.agilent.com/plugins/servlet/desk, in case the link Marty sent in his earlier message did not come through.  The local field team will likely be unable to resolve this issue and you need to speak with our Global Informatics Service Team at that site.  Please let us know if you have any issues submitting a support ticket online.

Was this helpful?