Firmware error

Hi everyone, we have an ICP-MS 8900, the next errors popped up today:

''Firmware error occurred while sending command: ICP-MS driver internal error.''

''Could not find ICP-MS. MassHunter will switch to offline mode.''

The equipment does not connect with the software. I tried to restart the computer, but It didn't work. The problem persists.

And the status of the ICP bar does not match any of what the manual says, I attach a video so you can see the status of the equipment (blinking between yellow and red):/cfs-file/__key/communityserver-discussions-components-files/45/WhatsApp-Video-2022_2D00_09_2D00_08-at-9.33.53-AM.mp4

So we don't know if the ICP can be turned off or restarted to see if it connects with the software again since we don't know what state the turbomolecular pump is in. On the other hand, the mechanical pump is working and nothing strange is detected by the naked eye.

  • To put the ICP-MS into shutdown mode manually, open the top cover and hold down the white vacuum on/off button close to the status indicator light until you hear a click, see image.

    After a few minutes the vacuum should slow down and turn off. Then it will be safe to power off the instrument and restart.

    Restart PC and instrument and then try to make connection through MassHunter whilst the ICP-MS is on but still in shutdown mode.

    Note: After turning on the main switch, the status indicator lamp turns on and stays red for about 2 minutes while the instrument powers up. Wait until the red lamp turns off before using the Vacuum ON/OFF Switch. The indicator light then flashes amber during pump down (vacuum on).

    I hope this may help.

Was this helpful?