4 Replies Latest reply on Aug 10, 2018 10:56 AM by berndh

    Report Parameters - "float" number format, comma separation


      Dear all,


      I have a small (at least I hope so) problem/language settings issue regarding number formats in the reporting module of OpenLAB CDS 2.3:


      Default values need to be entered with a "," as comma separator (which makes sense, I'm in Europe after all, same in acquisition and data analysis).

      Number output in the report itself uses a "." as comma separator.


      now, of course, I run into the issue that comparing for example a peak's tailing factor of 1.09 to the limit set via the report parameters (e.g. min. 0,8 and max 2,0) will not work as the system interprets the values of the report parameters as 8 and 20 respectively.


      I can work around that, theoretically, by multiplying the tailing factor by 10, but that seems rather inelegant and does not work for other usecases (where expected values can vary by more than a factor of ten)


      I do not find the option of changing a report's language settings - would that help? Or any other ideas?


      Thanks and best regards,

        • Re: Report Parameters - "float" number format, comma separation



          Just to clarify, are the affected values OpenLAB CDS 2.3 all custom parameters?

            • Re: Report Parameters - "float" number format, comma separation

              Good morning,


              yes - the number formats in setting up custom parameters and the report itself seem to be different:


              I need to set up the parameter using "," as comma - a "." does not work:


              If I recall the value in the report I get:

              ...15 instead of 1.5 as I would expect (number format of data is using "." as comma separator...:



              best regards,


                • Re: Report Parameters - "float" number format, comma separation

                  Hi Bernd,


                  Thank you for the detailed explanation. My question was more focused towards sample or compound customer parameters defined on the project level, not report parameters.





                  For customer parameters, their values are saved as strings by OpenLAB CDS. This then causes the issues when numeric values are formatted with commas instead of decimals.


                  A workaround for this is to set up a custom calculation file in the method that will call the custom parameter value correctly. For example, if you have a sample custom parameter named MaxTailing, the following expression in a CCF linked to the method would resolve this problem:




                  You can then call the result of this custom calculation on your report:




                  That might work for you if you are able to switch from a report custom parameter to a project customer parameter.

                  1 person found this helpful